{}

Our Brands

Impact-Company-Logo-English Black-01-177x54

Schneider Electric Gulf Countries and Pakistan Website

Welcome to our website.
Search FAQs
CM (Configuration Manager) Tool 2.0.0 - ION_Data archive is failing when historical data is selected
Issue
The CM (Configuration Manager) Tool 2.0.0 is failing on "Save to Archive" step when historical data is selected. Without 'Historical Data' selected, the tool completes and saves the archive successfully.

When historical data is selected, the CM tool produces the following message on the "Save to Archive" step.

"Save to Archive was cancelled."



The following error is displayed in the Configuration Manager log:

"The archive cannot be saved due to insufficient SQL Server write permissions to D:\Program Files (x86)\Schneider Electric\ION Enterprise. Save to a different location or edit the SQL Server service account permissions, and try saving again."

There is no package saved in the desired location.

Product Line
Configuration Manager (CM) Tool 2.0.x

Environment
Power Monitoring Expert System Configuration Backup

Cause
This issue may be the result of insufficient drive space on the desired output drive or insufficient privileges on the SQL Server service account in the desired output directory.

Resolution
Verify that the SQL Server service account has appropriate privileges on the Configuration Tool Archive output directory and run the Configuration Manager tool "As an Administrator"
Verify that there is an appropriate amount of free space on the desired output drive to hold the Archive output including the ION_Data historical data.

If the above items have been verified and the issue still persists, the archive can be generated manually by completing the following steps.

1. Save the archive without ION_Data historical data selected and unzip the archive to a known location.

2. Open the ComponenetCollection.json file with notepad (Located in the root folder for the archive) and add the following fragment:

{

"OperationType": 23,

"Processed": 1,

"Count": 1,

"Type": "Historical Data",

"ComponentItems": [

{

"Processed": true,

"Name": "ION_Data",

"DisplayName": "ION_Data",

"Attributes": [

{

"Name": "DatabaseName",

"Value": "ION_Data"

},

{

"Name": "Size",

"Value": "316669952"

},

{

"Name": "BackupSize",

"Value": "227540992"

},

{

"Name": "StartDate",

"Value": "2015-11-19T16:00:00.0000000"

},

{

"Name": "EndDate",

"Value": "2016-06-22T03:45:00.0000000"

}

]

}

]

},

3. Copy and paste the ION_Data.bak database backup file to the ...\Database_Backups folder in the unzipped Archive directory.

4. Zip the archive with the updated ComponenetCollection.json file and the ION_Data.bak file.

5. Start CM tool and perform "Load from Archive" to make sure that you can see the ION_Data metadata (start and  end date etc). The actual values do not matter so it is not a requirement to align them with the date range of the available data in the ION_Data.bak file that was manually added to the archive.

Schneider Electric United Arab Emirates

Explore more
Product:
Articles that might be helpful Users group

Discuss this topic with experts

Visit our Community for first-hand insights from experts and peers on this topic and more.
Explore more
Product: