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PME Web Alarms show "Unable to update the result. The server either timed out or returned invalid result."

Issue
After an upgrade, PME Web Applications Alarms tab does not show Alarms and red error message appears stating: 'Unable to update the result. The server either timed out or returned invalid result. If this problem persists please contact the system administrator.'

PME web alarms page

The following errors appear in the [ApplicationModules].[Diagnostic].[LogEvent].

A problem occurred on page 'https://........./Alarms/data/incidents': Could not find file 'C(Drive name where PME installed):\Program Files (x86)\Schneider Electric\Power Monitoring Expert\system\etc\EnumAndEvent.en-US.resx'.

A problem occurred on page 'https://........./Alarms/data/alarmdefinitions': Could not find file 'C(Drive name where PME installed):\Program Files (x86)\Schneider Electric\Power Monitoring Expert\system\etc\IonNames.en-US.resx'.

    • (In PME 2020 and newer, the [ApplicationModules].[Diagnostic].[LogEvent], has been integrated into the system log that can be viewed from PME's Web Application)


Product Line
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024


Environment
Web Applications

Cause
The language associated with EnumAndEvent.en.resx and IonNames.en.resx are not reading correctly.

Resolution
*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*
*Warning: Take backups of any files prior to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).*

First use the following steps to confirm what errors are inside the ApplicationModules event log:

  1. Log into the SQL server through SQL Server Management Studio
  2. Open Databases > ApplicationModules > Tables
  3. Find Diagnostics.LogEvent Table right click and Select Top 1000 Rows.
  4. Add new line with to the bottom of the script: order by TimeStamp desc
  5. Click on 'Execute' button

If the errors from the Issue section above appear inside of the ApplicationModules event log then the 2 files from the errors need to be altered.

  1. Go to the folder C:(or Drive name where PME installed):\Program Files (x86)\Schneider Electric\Power Monitoring Expert\system\etc\
  2. Find the files, EnumAndEvent.en.resx and IonNames.en.resx
  3. Create backups of these files.
  4. Rename the files to match the error:
    1. Rename EnumAndEvent.en.resx to EnumAndEvent.en-US.resx
    2. Rename IonNames.en.resx to IonNames.en-US.resx
  5. After the file is renamed, close the Web Application, reopen the Alarm page, and the alarms appear.
Note: An iisrest may be required for the change to take affect.






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