{}

Our Brands

Impact-Company-Logo-English Black-01-177x54

Schneider Electric Gulf Countries and Pakistan Website

Welcome to our website.
Search FAQs
Product and Version fields are blank in the Schneider Electric Software Installer when installing EcoStruxure Machine Expert
Issue
I'm trying to install EcoStruxure Machine Expert, but the Product and Version fields are blank in the Schneider Electric Software Installer.
There are two cases in which this can occur:

Case 1) There is no connection between the PC and the Schneider Electric file server:
The message "Updating product and version list. Please wait for the process to complete..." and a spinning green arc loading symbol won't go away.
In the top corner, there is a message "Not connected to Schneider Electric's server"
Case 1 - Schneider Electric Software Installer blank Product and Version dropdowns

Case 2: There is a connection, but the Schneider Electric Software Installer Tool cannot write the information to the local directory.
In this case, the screen will appear almost the same, however, without the two messages:
"Not connected to Schneider Electric's server" indicator at the top-right of the window
"Updating product and version list" indicator at the bottom-left.
Case 2  - Schneider Electric Software Installer blank Product and Version dropdowns

Product Line
Schneider Electric Software Installer Tool

Products that can currently be installed with this tool include:
EcoStruxure Machine Expert v1.2, v2.0
EcoStruxure Operator Terminal Expert
SoSafe Configurable
Floating License Manager
EcoStruxure Machine Expert Twin

This Software Installer tool has frequent updates and new products are added to the server as they come out.


Environment
Installation Tool in Windows

Cause
Case 1 is caused by no connection to the Schneider Electric software server either because of no connection to the Internet or the domain or port is blocked by the network the PC is on by IT.

Case 2 occurs if My Documents on the PC is mapped to a network folder path.
One can check this by launching the Schneider Electric Software Installer tool and clicking the "Hammer & Wrench" button at the top-right corner.
Choose "Download Full software version":
Download Full software version button

If the next screen appears with the message: "Access to the path: '\\<Network Folder Path>\Users\Downloads\OfflineMedium' is denied".
That would indicate that this is indeed Case 2.

The Schneider Electric Software Installer Tool writes to the the Windows default directories to store information (available software) from the Server, and if it cannot access the folder, you will get this message:
Creating an Offline medium message popup


Resolution
Case 1 - Connection to Server:
In this case, in order to have the installer in working order, follow these steps:
1) Ensure that your PC has a connection to the Internet and there is no network infrastructure blocking it from connecting to the URL: https://www.seupdate.schneider-electric.com
2) Ensure the port that needs to be open to this endpoint, port 443 for https is not blocked
3) Depending on your network, you may also check with your local IT department if they need to provide a proxy to connect to the server.

Case 2 - Default My Documents folder path in Windows:
In this case, in order to have the installer in working order, follow these steps:
1) Close the Schneider Electric Software Installer tool.
2) Configure the Windows My Documents folder path to one that is on the local disk C:\ rather than the "\\<Network Folder Path>\"
For more information on this, refer to the Microsoft topic: "Configuration of the My Documents Folder" article or talk to your Network and IT Administrator.
3) Once the My Documents folder path is now in your local disk, launch the Schneider Electric Software Installer again.


If this FAQ did not solve your issue, you can chat with us at chat with us or e-mail us at customer.services@se.com to create a case with our Technical Support Team.

If you are not located in North America, please contact your local Customer Care Center for assistance:
Support | Schneider Electric Global (se.com)

Schneider Electric United Arab Emirates

Explore more
Range:
Articles that might be helpful Users group

Discuss this topic with experts

Visit our Community for first-hand insights from experts and peers on this topic and more.
Explore more
Range: