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Power Monitoring Expert v9.0 - Configuration Manager Tool v9 fails with below errors while Read from System’ in PME v9.0 machine.
Issue
When running ‘Read from System’ exceptions are thrown while -
Reading Operating System Information, Reading Alert Monitor, Reading Custom ION Frameworks, Reading Custom Reporting Date Ranges, Reading Custom Report Definition Files, Reading Custom Report Packs, Reading Customized Device Types, Reading Customized Diagrams, Reading Billing Rates, Reading EWS Server, Reading Web Application
||||Information||None||Alert Monitor||Exception call stack    at ConfigurationManager.Product.Business.Jobs.Utilities.RegistryHelper.GetRegistryKeyValueFromLocalMachine(String keyName)
at ConfigurationManager.Product.Business.Jobs.Readers.ReaderJobBase.get_InstallationPath()
at ConfigurationManager.Product.Business.Jobs.Readers.FileReader.GetInputs(ComponentCollection`1 componentCollection)
at ConfigurationManager.Product.Business.Jobs.Readers.FileReader.Execute(ComponentCollection`1 componentCollection, CancellationTokenSource cts)
at CallSite.Target(Closure , CallSite , Object , ComponentCollection`1 , CancellationTokenSource )
at System.Dynamic.UpdateDelegates.UpdateAndExecuteVoid3[T0,T1,T2](CallSite site, T0 arg0, T1 arg1, T2 arg2)
at CallSite.Target(Closure , CallSite , Object , ComponentCollection`1 , CancellationTokenSource
at ConfigurationManager.Product.Business.Jobs.ProductConfigurationReader.Execute (ComponentCollection`1 configItems, CancellationTokenSource cts).||Businesse



Environment
Power Monitoring Expert v9.0 system read by Configuration Manager Tool v9


Cause
This issue is triggered whenever there are registry entries less than the current PME version number.  ie.  1.0 and 9.0 under the PME root registry key will cause exceptions to be thrown.
This error is mainly observed in the PME systems where Azzo plugins are installed. When Azzo plugin is installed (Ex: Expert System Diagnostic), this will create a registry key “1.0” under ‘HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\Power Monitoring Expert’. CM Tool expect only 8.2 / 9.0 (version of PME) under Power Monitoring Expert path.




Resolution
Take backup of 1.0 registry by exporting it (HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\Power Monitoring Expert\1.0) and then deleted this key ‘1.0’, now I run the fresh CM tool and complete ‘Read from system’ and Save to Archive’ operations. Once finished all activity import the key back in system registry.

Or Just rename 1.0 folder to 9.8 and after finishing CMT operation revert it back from 9.8 to 1.0
Note: This issue is fixed in PME 2020 CM Tool version.

Schneider Electric Australia

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