Consulter notre FAQ
Power Monitoring Expert v9/2020: EWS Client could not connect to PME over EWS
Issue
EWS Reference client show below error while connecting with PME, even though proper EWS credentials are entered or EBO software unable to connect to PME over EWS.
Environment
Power Monitoring Expert v9.0
Power Monitoring Expert v2020
EWS Reference Client v2.0 (Beta)
Cause
By default, the EWS server in PME is configured for HTTP client connections. But from PME v9.0 onwards PME uses Transport Layer Security (TLS) 1.2 for an encrypted, authenticated connection using HTTPS between the server and its web clients and hence the default configuration of the software only allows HTTPS connections between the PME application server and the web clients.
Resolution
It is must to configure the PME to host EWS server for HTTPS. This has been explained in the “PME v9/2020 User Guide” under the section “Configuring the PME EWS server for HTTPS” and same steps are as below –
To configure the EWS server for HTTPS client connections:
1. On the PME server, open the web.config file for editing, for example in Notepad. You can
find this file in ...\Power Monitoring Expert\applications\EWS.
2. Search for the <binding name="DataExchange_BP11Binding"> element in the file.
Find the <httpTransport ... /> child element and change it to <httpsTransport
... />.
3. Search for the <behavior name="DataExchange_BP11Behavior"> element in the file.
Find the <serviceMetadata httpGetEnabled="true" /> child element and add the
httpsGetEnabled="true" attribute. After the change the element should look like this:
<serviceMetadata httpGetEnabled="true" httpsGetEnabled="true"/>.
4. Save the web.config file. Close the file.
5. Restart Internet Information Services (IIS) on this computer.
Now you can able to connect PME EWS Server over HTTPS using Authentication method as ‘HTTP Auth Digest’ in EWS Reference Client tool.
Endpoint: https://PMEServerName/EWS/DataExchange.svc?wsdl
Note: EWS Reference Client tool can be downloaded from KB - FA269362
EWS Reference client show below error while connecting with PME, even though proper EWS credentials are entered or EBO software unable to connect to PME over EWS.
Environment
Power Monitoring Expert v9.0
Power Monitoring Expert v2020
EWS Reference Client v2.0 (Beta)
Cause
By default, the EWS server in PME is configured for HTTP client connections. But from PME v9.0 onwards PME uses Transport Layer Security (TLS) 1.2 for an encrypted, authenticated connection using HTTPS between the server and its web clients and hence the default configuration of the software only allows HTTPS connections between the PME application server and the web clients.
Resolution
It is must to configure the PME to host EWS server for HTTPS. This has been explained in the “PME v9/2020 User Guide” under the section “Configuring the PME EWS server for HTTPS” and same steps are as below –
To configure the EWS server for HTTPS client connections:
1. On the PME server, open the web.config file for editing, for example in Notepad. You can
find this file in ...\Power Monitoring Expert\applications\EWS.
2. Search for the <binding name="DataExchange_BP11Binding"> element in the file.
Find the <httpTransport ... /> child element and change it to <httpsTransport
... />.
3. Search for the <behavior name="DataExchange_BP11Behavior"> element in the file.
Find the <serviceMetadata httpGetEnabled="true" /> child element and add the
httpsGetEnabled="true" attribute. After the change the element should look like this:
<serviceMetadata httpGetEnabled="true" httpsGetEnabled="true"/>.
4. Save the web.config file. Close the file.
5. Restart Internet Information Services (IIS) on this computer.
Now you can able to connect PME EWS Server over HTTPS using Authentication method as ‘HTTP Auth Digest’ in EWS Reference Client tool.
Endpoint: https://PMEServerName/EWS/DataExchange.svc?wsdl
Note: EWS Reference Client tool can be downloaded from KB - FA269362
Publié pour:Schneider Electric Belgium
En savoir plus
Gamme :
En savoir plus
Gamme :