Consulter notre FAQ
Why does the Augmented Operator Advisor's Manager Webpage appear with a 404 page?
Issue
When running Augmented Operator Advisor, and attempting to navigate to the embedded Manager Webpage, an "HTTP Error 404.0 - Not Found" page appears in the web browser with Detailed Error Information:
Error Code: 0x80070002.
Physical Path: "C:\inetpub\wwwroot\AugmentedOperatorManager\login"
Example:
Product Line
EcoStruxure Augmented Operator Advisor
Cause
In this specific case, the AOANginx Windows Service cannot start because another Windows process is using Port 80 - which the AOA Runtime requires.
Resolution
When we see that the "Check ports" window shows "Error -port busy with another process : System", we will need to look into what Windows process is reserving that port.
In this specific example, we know that Windows Internet Information Services (IIS) is using Port 80 because the Physical Path is directed to "C:\inetpub\wwwroot\" - which is the default folder for Windows IIS.
That means the solution would be one of three options:
1) Change the port of IIS to something other than port 80
2) Stop the IIS Web Server if it is not being used.
3) Modify the port of the AOA Runtime Server to a port that is free (e.g. 82, 83, 8080, 8081 - check with your IT department what would be a suitable port for your managed network)
If it is NOT Windows IIS that is using the same port as AOA Manager:
1) To check all the ports on a Windows machine, one can use the command line Netstat command.
This command will give you the Windows Process ID (PID) of the application or service that is using the port.
See: https://learn.microsoft.com/en-us/windows-server/administration/windows-commands/netstat
2) Afterwards, open the Windows Task Manager to identify the name of the application or service that is that PID number.
3) Decide on whether you just need to (a) deactivate that application/service, (b) change the port number for that application/service if possible, or (c) change the port number for AOA Runtime Manager.