Issue:
When launching Vijeo Designer Runtime simulation mode, the project starts to validate and build, but the runtime simulation window does not open.
Product Line:
Vijeo Designer all versions
Resolution:
Possible Cause #1:
When Vijeo Designer Runtime Simulation cannot start, it is possible that a system file is missing. In one situation, the "ewfapi.dll" file can be missing. When this file does not exist, the runtime simulation will not start. To resolve this, please copy the file "ewfapi.dll" from "C:\Program Files\Schneider Electric\Vijeo-Designer\Vijeo-Frame\" to "C:\Program Files\Schneider Electric\Vijeo-Designer\Vijeo-Runtime\public\bin"
Possible Cause #2:
Another possibility is that your application has a validation error or build error that you cannot see because feedback zone window is hidden. Be sure to check that you can see the results of the feedback zone. Press Shift+F6 to bring the window back up if it is missing.
Possible Cause #3:
A third possibility is that you have the Limited Edition version of Vijeo Designer installed. This version restricts the use of Simulation and Download to only the HMISTU and HMISTO target families. To check if you have Limited Edition, goto Help->About. If the general tab indicates Limited Edition, you will not be able to use Simulation for any model other than the HMISTU or HMISTO. Please uninstall this version and install Vijeo Designer full (licensed copy).
Possible Cause #4:
A fourth possibility is that the process "Koohi.exe" is stuck in the Windows Task manager. Try to manually end this task in the Windows Task Manager and start the Simulation again.
If the problem still persists, please contact Schneider Electric Technical Support:
https://www.se.com/us/en/work/support/customer-care/brand-selection/
When launching Vijeo Designer Runtime simulation mode, the project starts to validate and build, but the runtime simulation window does not open.
Product Line:
Vijeo Designer all versions
Resolution:
Possible Cause #1:
When Vijeo Designer Runtime Simulation cannot start, it is possible that a system file is missing. In one situation, the "ewfapi.dll" file can be missing. When this file does not exist, the runtime simulation will not start. To resolve this, please copy the file "ewfapi.dll" from "C:\Program Files\Schneider Electric\Vijeo-Designer\Vijeo-Frame\" to "C:\Program Files\Schneider Electric\Vijeo-Designer\Vijeo-Runtime\public\bin"
Possible Cause #2:
Another possibility is that your application has a validation error or build error that you cannot see because feedback zone window is hidden. Be sure to check that you can see the results of the feedback zone. Press Shift+F6 to bring the window back up if it is missing.
Possible Cause #3:
A third possibility is that you have the Limited Edition version of Vijeo Designer installed. This version restricts the use of Simulation and Download to only the HMISTU and HMISTO target families. To check if you have Limited Edition, goto Help->About. If the general tab indicates Limited Edition, you will not be able to use Simulation for any model other than the HMISTU or HMISTO. Please uninstall this version and install Vijeo Designer full (licensed copy).
Possible Cause #4:
A fourth possibility is that the process "Koohi.exe" is stuck in the Windows Task manager. Try to manually end this task in the Windows Task Manager and start the Simulation again.
If the problem still persists, please contact Schneider Electric Technical Support:
https://www.se.com/us/en/work/support/customer-care/brand-selection/