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A generic diagram for the selected device cannot be found" error message appears in PME Vista

Issue
Vista diagrams will not open and provide the error "A generic diagram for the selected device cannot be found."

Product Line
PME 7.2.x, 8.x, 9.x, 2021, 2022, 2023
SPM 7.0.1
ION Enterprise

Environment
Vista
Web Applications

Cause
The generic diagram does not exist in the file folder or the device does not exist in the registry.

Resolution
Check and see if the meter icon is pointed to the correct place in Vista.

1. Open up the Vista diagram with the desired meter icon.
2. In the menu bar go to 'options' and make sure the 'show toolbox' option is selected.
3. Right click on the meter icon and a 'Grouping Object Configuration' window will appear.
4. Click on the 'action' tab.
5. Click on the 'Open Diagram for Meter Template' option if it is not selected.
6. Click 'OK' to close the configuration window.
7. Try to open the Vista diagram by double-clicking on it.

If it still does work, check that the generic diagram exists in the correct folder.
  1. Go to the directory ...Power Monitoring Expert\config\diagrams\ud\default
  2. Check that the diagram exists for the meter type.
  3. If the diagram does not exist one will need to be placed into this folder.
If the diagram does exist and the number of diagrams that need to be corrected is small, an option is to manually force the Vista diagram to look in the correct place.
  1. Go into the action tab of the 'Grouping Object Configuration' window, as was done above.
  2. Click on the 'Open User Diagram' button.
  3. Browse to the desired diagram and click 'OK'.
  4. Double-click the icon to check and see if the Vista diagram opens.
If the diagram does exist and the number of diagrams that need to be corrected is large, it is likely that the registry lacks the device types that are trying to be viewed. This is common in PME 9.0 installation for CM2000s and PM600s. The below example is for CM2000s and PME 9.0.
*Warning: This article contains information about editing the registry. Improper changes to the registry can permanently damage the operating system. Always back up the registry before making any changes.*
  1. Open RegEdit.
  2. Check if the device exists in HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\Power Monitoring Expert\9.0\DeviceInfo. The following images lack the CM2000s entries
Reg edit example
  1. If they do not exist, find a PME 9.0 or PME 8.2 with the missing entries. This example used PME 8.2.
Reg edit example 2
  1. Right click on each of the entries needed and select export. In this example the entry for CM2000, CM2050, CM2150, CM2250, CM2350, CM2450, and CM2452 would each need to be exported.
  2. Give the file any name that makes sense and save it.
  3. After the files are saved right click on the exported file and select edit.
Reg edit example 3
  1. Change the file path to match the system that lacks the entries. In this example change 8.2 to 9.0.
reg edit example 4
  1. After the changes are made save the file. Do this for each entry.
  2. Move the files to the server with the issue.
  3. Right-click the file and select merge.
  4. A warning will appear. Please heed this warning and if confident proceed.
  5. Once all entries have been merged into the registry the diagrams will open.

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