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Troubleshooting - Usb PLC Service does not start and I cannot connect my PC to my Modicon PLC via USB cable
Issue
Troubleshooting - When I try to connect my Modicon PLC to my computer via USB connection, the Windows USB driver cannot detect it and the "Usb PLC" service does not start.
Product Lines
EcoStruxure Control Expert (Unity Pro v12+): Unity Quantum PLCs, Modicon M340, M580, MC80
SoMachine Basic / EcoStruxure Machine Expert Basic: Modicon M221
SoMachine v4.1+: Modicon M258 PLC, Modicon LMC058 Motion Controller, ATV-IMC Driver
EcoStruxure Machine Expert: Modicon M258, M262, LMC058
Schneider Electric PLCUsb Driver x64 Suite
Environment
Windows 7
Windows 8.1
Windows 10
USB Drivers
Resolution
This FAQ will go through some troubleshooting steps on this topic specifically if the Usb PLC Windows Service does not run.
Before going through the following steps, please contact Schneider Electric Support to obtain the latest 'PLCUsb Driver X64' Suite. This Microsoft signed driver package is compatible with all PLC families from EcoStruxure Machine Expert (SoMachine) and EcoStruxure Control Expert (Unity Pro).
In EcoStruxure Control Expert's installation DVD .ISO image, this will be located in the "Communication Drivers" folder, or you may download the latest version (as of Sept 2022) from the bottom of this FAQ.
For Windows 7 or 8.1: "SchneiderPLCUSBDriverSuite (14.13.0.0) Win7.zip"
For Windows 10: "SchneiderPLCUsbDriverSuite (v14.15.0.0) Win10.zip"
Section A) Check if the Windows cannot verify the digital signature of the PLC:
Section B) Check if the 'Usb PLC' service is running:
we will need to remove the 'Usb PLC' service from Windows:
Section G) Identify and Remove Duplicate Devices in the Device Manager (specifically for M340 only)
Section H) Check for RasClient Error (EventID: 20227) in Windows Event Viewer - Application log folder (specifically for M340)
Specifically for the M340 PLC connection, you may see this combination of symptoms:
Steps to recognize this issue:
Steps to solve this issue from the video:
If the issue persists after these troubleshooting steps, please contact Schneider Electric Customer Care.
Section I) Check if the Windows Ethernet is Reaching Out to the Internet for IP Address 90.0.0.1 Instead of the Local COM port:
In this case, the symptoms will be as follows:
In this case, go to Windows Settings > Network & Internet > Proxy
And deactivate "Use a proxy server".
Other solutions may include one of the following (NOTE: do no do this without IT help in case of special settings rolled out for your computer by your IT):
- Deactivating any other IPv4 or IPv6 Transition Technologies
- Resetting the TCP/IP Stack with cmd commands:
netsh i r r
netsh winsock reset
- Uninstall Suspected applications that could be redirecting the traffic.
Section J: Virtual Machines
Symptom:
When using EcoStruxure Control Expert in a Virtual Machine and the Driver inside the VM does not install properly in the Windows Device Manager upon the cable being plugged in.
You may even see that the plcusb.sys file from C:\Windows\System32\Drivers\ folder may be deleted by the OS when this occurs.
Cause:
The cause can be an issue with when the PC Host physical machine has the original connection, and a failure in the OS passing the USB cable connection to the Virtual Machine (possibly a BIOS firmware issue tied to hardware).
Recommendation:
Turn off automatic assignment of the USB device to the VM.
Section K: Dell Precision Laptops
Symptom:
The USB ports on the sides of the Dell Precision 7550 laptop do not work with the USB connection to PLCs.
Cause:
This could be either BIOS or hardware related. The root cause is undetermined at this time.
Recommendation:
If this FAQ did not solve your issue, you can chat with us at chat with us or e-mail us at customer.services@se.com to create a case with our Technical Support Team.
If you are not located in North America, please contact your local Customer Care Center for assistance:
Support | Schneider Electric Global (se.com)
Troubleshooting - When I try to connect my Modicon PLC to my computer via USB connection, the Windows USB driver cannot detect it and the "Usb PLC" service does not start.
Product Lines
EcoStruxure Control Expert (Unity Pro v12+): Unity Quantum PLCs, Modicon M340, M580, MC80
SoMachine Basic / EcoStruxure Machine Expert Basic: Modicon M221
SoMachine v4.1+: Modicon M258 PLC, Modicon LMC058 Motion Controller, ATV-IMC Driver
EcoStruxure Machine Expert: Modicon M258, M262, LMC058
Schneider Electric PLCUsb Driver x64 Suite
Environment
Windows 7
Windows 8.1
Windows 10
USB Drivers
Resolution
This FAQ will go through some troubleshooting steps on this topic specifically if the Usb PLC Windows Service does not run.
Before going through the following steps, please contact Schneider Electric Support to obtain the latest 'PLCUsb Driver X64' Suite. This Microsoft signed driver package is compatible with all PLC families from EcoStruxure Machine Expert (SoMachine) and EcoStruxure Control Expert (Unity Pro).
In EcoStruxure Control Expert's installation DVD .ISO image, this will be located in the "Communication Drivers" folder, or you may download the latest version (as of Sept 2022) from the bottom of this FAQ.
For Windows 7 or 8.1: "SchneiderPLCUSBDriverSuite (14.13.0.0) Win7.zip"
For Windows 10: "SchneiderPLCUsbDriverSuite (v14.15.0.0) Win10.zip"
Section A) Check if the Windows cannot verify the digital signature of the PLC:
- Open the Windows Device Manager
- Find the device in the list:
- M340 will appear under "Modems" as: "BMX CPU" or "BMX CPU #x" (where x is an integer)
- M580 will appear under "Network adapters" as: "SE RNDIS PSX M580 Controller"
- M262 will appear under "Network adapters" as: "SE RNDIS PSX M262 Controller"
- Right-click the device node
- Go to Properties
- In the General tab, check if the Device Status shows: "Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)"
- If you see this message it will likely mean that you have a driver that is older than v14.13.0.0 which was a version not signed by Microsoft before 2019 when Microsoft required Digital Signatures for all USB drivers. Skip to section E below to uninstall and reinstall the latest driver.
Section B) Check if the 'Usb PLC' service is running:
- Click the Windows Start button.
- Run "Services.msc".
- Scroll down to the Service names that start with the letter 'U'.
- In the row named "UsbConnect" and description "Usb PLC", check the Status column.
- If the Status column is blank or Stopped, right click on the row and choose "Start".
- If this is not possible or an error appears, check the Startup Type, is it blank?
- If so, Right-click on the row and go to Properties.
- Change the Startup Type to Manual, and Start the Service with the Start button.
- If an error appears "Windows could not start the Usb PLC service on Local Computer. Error 2: The system cannot find the file specified." go to the next set of steps.
- Right-click on the Windows Taskbar and choose "Task Manager" (or Ctrl+Alt+Delete and choose "Task Manager")
- Go to the Details Tab in the Windows Task Manager.
- Scroll down to the process names starting with the letter 'U'
- Check if 'UsbConnect.exe' and 'UsbConsole' are running.
- If they are not running, go to C:\Windows\System32\ to see if UsbConnect.exe and UsbConsole.exe appear at this folder level. If they do not,
we will need to remove the 'Usb PLC' service from Windows:
- Unplug the USB cable from your PC
- Close the File Explorer open to "C:\Windows\System32\".
- Close the Services window (services.msc).
- Run CMD in Administrator Mode.
- If the location is not already 'C:\WINDOWS\System32\', change the directory with the command: cd C:\windows\system32\
- Type: sc delete "Usb PLC"
- Hit the Enter key. This will remove the Usb PLC service from your computer's registry.
- Run services.msc, once again to confirm it is removed.
- Go to Windows Control Panel-> Programs and Features.
- Find "PLCUsb Driver X64".
- Right-click on it and Uninstall.
- Restart your PC.
- Continue to Section F.
- Install the new PLCUsb Driver X64 suite.
- Restart your PC.
- Go to Services.msc and check that the 'Usb PLC' service is Running.
- Go to Task Manager and check that 'UsbConnect.exe' and 'UsbConsole.exe" are running.
- Plug in the USB cable connecting the PLC to your PC.
- Go to Windows Device Manager.
- Expand the 'Modem' node.
- If there is a yellow triangle by the node of the PLC, right-click on that node and "Uninstall Device".
- Once the device disappears from your Device Manager, unplug the PLC's USB cable from your PC.
- Wait 30 seconds.
- Plug the PLC back into the USB port of the PC.
If at Step 4 the UsbConnect.exe and UsbConsole.exe are NOT running, try running C:\Windows\System32\UsbConnect.exe directly from Windows File Explorer as Administrator. This should spawn both "UsbConsole" and "USB PLC NT Service" in the Task Manager:
If the are not running, then check with the Administrator of your computer to see if they are being blocked by:
Group Policy, Firewall, Anti-malware software, or Antivirus software.
If the are not running, then check with the Administrator of your computer to see if they are being blocked by:
Group Policy, Firewall, Anti-malware software, or Antivirus software.
Section G) Identify and Remove Duplicate Devices in the Device Manager (specifically for M340 only)
- Open the Windows Device Manager.
- Click on View
- Select 'Show hidden devices'
- Expand the Modems item.
- Delete the BMX CPU devices found under Modems
- If there are any unknown devices found under Modems, delete those also.
- Retest
Section H) Check for RasClient Error (EventID: 20227) in Windows Event Viewer - Application log folder (specifically for M340)
Specifically for the M340 PLC connection, you may see this combination of symptoms:
- The BMX CPU instance in Device Manager will appear as working properly
- However, when you launch the Drivers Manager (SCHNEIDER Drivers Management Properties), click on the PLC USB Driver tab, click on the [More...] button, it shows:
- Status: <blank>
- Remote IP : <blank>
- Local IP : <blank>
- Standard SE USB connection log: "No (or active) USB connection: Plug (or replug) USB cable"
- Normally, when the M340 is detected as connected via USB, the PLC USB Driver Diagnostic should show:
- Status : <blank>
- Remote IP : 90.0.0.1
- Local IP: 90.0.0.2
- Standard SE USB connection log: "<lineNumber>:<Timestamp>->Active USB-connection: 'USBCON'"
Steps to recognize this issue:
- Run the Windows Event Viewer
- On the top-left pane, choose "Application"
- At the timestamp of when you plugged in the USB cable, check to see if you have an Error with:
- Source = RasClient
- Event ID = 20227
- General Error Message: "The user SYSTEM dialed a connection named USBCON which has failed. The error code returned on failure is 720."
- If this is observed, then follow the instructions in this Video: How to Correct Control Expert Not Able to Connect with M340 Using USB | Schneider Electric Support
Steps to solve this issue from the video:
- Run the Windows Registry Editor (regedit.msc)
- Go to Edit -> Find... (or hit Ctrl+F)
- Search for the GUID (General Unique ID) string: "{4D36E972-E325-11CE-BFC1-08002BE10318}".
- Observe that in the Registry Editor, this highlights "Computer\HKEY\LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\"
- Right click on this folder and choose "Export" to save a backup of this folder.
- Once you have saved the file, expand the folder in the Registry Editor.
- Select each folder "0000", "0001", "0002"
- carefully search for the name 'DriverDesc' with the Data 'WAN Miniport (PPTP)" and delete just that row.
- carefully search for the name 'DriverDesc' with the Data 'WAN Miniport (IP)" and delete just that row.
- DO NOT Delete any other rows with the name DriverDesc.
- Open Windows Device Manager
- Navigate to "Network adapters" and expand it
- Right-click on "WAN Miniport (IP)"
- Choose "Uninstall device"
- Right-click on "WAN Miniport (PPTP)"
- Choose "Uninstall device"
- Scan for hardware changes to reinstall the WAN Miniport (IP) and WAN Miniport (PPTP) drivers. There are two methods:
- Right-click on the name of the computer -> choose "Scan for hardware changes" or
- Click the button on the toolbar that looks like a magnifying glass over a monitor.
- Open Powershell or Command Line (cmd.exe) as Administrator
- Type the command "netsh int IP reset - this will reset the Windows TCP/IP stack
- Unplug the USB cable from your PC
- Power cycle the M340 PLC
- Plug the USB cable back into the PC to connect the M340 PLC again
- Test your connection from EcoStruxure Control Expert
If the issue persists after these troubleshooting steps, please contact Schneider Electric Customer Care.
Section I) Check if the Windows Ethernet is Reaching Out to the Internet for IP Address 90.0.0.1 Instead of the Local COM port:
In this case, the symptoms will be as follows:
- When the cable from the PLC is plugged in, the details of the PLC node shown in the Device Manager shows no errors and the driver shows that it is installed successfully.
- When the cable from the PLC is plugged in, go to the SE Driver Manager console from SCHNEIDER Drivers Management Properties > PLC USB Driver tab > [More...], here you actually see:
- "Active USB-connection: 'USBCON'" which indicates an active successful USB connection.
- When you try to test the connection from EcoStruxure Control Expert via the PLC > Connect dropdown, it returns the popup message: "This isn't a valid PLC Address, or PLC is busy, or media is off."
- Pinging the IP Address 90.0.0.1 from Windows Command Line (cmd.exe) returns "General failure" (usually, if nothing is connected via USB, it should return "Request timed out."
In this case, go to Windows Settings > Network & Internet > Proxy
And deactivate "Use a proxy server".
Other solutions may include one of the following (NOTE: do no do this without IT help in case of special settings rolled out for your computer by your IT):
- Deactivating any other IPv4 or IPv6 Transition Technologies
- Resetting the TCP/IP Stack with cmd commands:
netsh i r r
netsh winsock reset
- Uninstall Suspected applications that could be redirecting the traffic.
Section J: Virtual Machines
Symptom:
When using EcoStruxure Control Expert in a Virtual Machine and the Driver inside the VM does not install properly in the Windows Device Manager upon the cable being plugged in.
You may even see that the plcusb.sys file from C:\Windows\System32\Drivers\ folder may be deleted by the OS when this occurs.
Cause:
The cause can be an issue with when the PC Host physical machine has the original connection, and a failure in the OS passing the USB cable connection to the Virtual Machine (possibly a BIOS firmware issue tied to hardware).
Recommendation:
Turn off automatic assignment of the USB device to the VM.
- In Device Manager, right-click on the PLC and Uninstall
- Unplug the USB cable
- Plug in the USB cable again
- When asked whether or not to assign to the USB connection to the Host (physical PC) or Virtual Machine, choose the Virtual Machine.
- You may also need to delete the hidden past connections (instructions in Section G).
Section K: Dell Precision Laptops
Symptom:
The USB ports on the sides of the Dell Precision 7550 laptop do not work with the USB connection to PLCs.
Cause:
This could be either BIOS or hardware related. The root cause is undetermined at this time.
Recommendation:
- Use the USB port(s) located on the back of the laptop.
- Depending on the Dell model, there may a conflict in the COM ports assigned by Dell software which comes with the laptop and you may also need. You may also need to delete some of them from the Registry. Check with your local IT Administrator for help doing this. See external article on this Windows-specific topic (valid for Windows 7 and Windows 10): https://woshub.com/how-to-clean-up-and-reset-com-ports-in-windows-7/
If this FAQ did not solve your issue, you can chat with us at chat with us or e-mail us at customer.services@se.com to create a case with our Technical Support Team.
If you are not located in North America, please contact your local Customer Care Center for assistance:
Support | Schneider Electric Global (se.com)
Udgivet til:Schneider Electric Danmark
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