{}

Our Brands

Impact-Company-Logo-English Black-01-177x54

Welcome to the Schneider Electric Website

Welcome to our website.
Search FAQs
PM800 display locked/frozen on amps per phase

Issue
PM800 display has locked/frozen on Amps and volts screen. Due to this reason, the real time values are not fluctuating from front display.

Product Line
PM800 series meter

Cause
PM800 display readings are locked/frozen.

Environment
Reading real-time values from front display of PM800 series meter.

Resolution

Resolution 1
Customer can power cycle the PM800 meter.

*Warning: Installation and maintenance of this device should only be performed by qualified, competent personnel that have appropriate training and experience with high voltage and current devices. Failure to follow the instructions / warnings in the Meter Installation Guide can result in permanent damage to the meter, severe injury or death.

Resolution 2
If power cycle doesn’t fix the issue, then the following is an isolated issue which has been seen a few times in the past.

The issue is the RJ-11 cable (Remote display cable) has gone bad and is no longer transmitting data properly to the meter. Replace the cable with a known working cable to resolve the issue!

Schneider Electric Hong Kong

Explore more
Range:
Articles that might be helpful Users group

Discuss this topic with experts

Visit our Community for first-hand insights from experts and peers on this topic and more.
Explore more
Range: