{}

Our Brands

Impact-Company-Logo-English Black-01-177x54

Welcome to the Schneider Electric Website

Welcome to our website.
Search FAQs
Does Schneider Electric authorize warranty claim for shipping damage?

Issue:
Product received with shipping damage.

Product Line:
M-Flex

Environment:
None

Cause:
Freight carrier did not transport product correctly

Resolution:
Unfortunately if the order did not have FOB (Freight on board)  then the customer should sign as damaged and file a claim against the carrier.

Schneider Electric Hong Kong

Explore more
Range:
Articles that might be helpful Users group

Discuss this topic with experts

Visit our Community for first-hand insights from experts and peers on this topic and more.
Explore more
Range: