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PowerSCADA Expert 8.x: ETL tools generates an empty CSV file when using the 'Delimited File Load Task v2'
Issue
An empty CSV file with headers only is generated when using the 'PowerSCADA Expert' extract task and the 'Delimited File Load Task v2' to export data.
Empty CSV file

Product Line
PowerSCADA Expert 8.x

Environment
​Extract, Transform & Load Tool (ETL) 1.4 or earlier

Cause
The Delimited File Load Task v2 is not compatible with the 'pair group' data that the PSE extract task outputs. This is slightly different than the 'pair' data that is output by the majority of the existing extract tasks.

Resolution
*Warning: Take backups of any files prior to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).

Note: View the 'Hotfix Deployment Instructions.txt' file contained in the'ETL PowerSCADA v1.4 Hotfix 72102.zip' (attached to this article) for additional details.

ThisHotfix 72102 for ETL (PSE to PME) v1.4 addresses the way the Delimited File Load Task V2 handles inbound data from a 'pair group' extract task such as the PowerSCADA Extract Task.

Instructions for installing the hotfix:
1. Stop all windows services that are associated with ETL jobs.
  • First, stop any existing ETL services that were created with PowerSCADA ETL v1.4. Open the ETL admin UI (TacticalSolutionsManager.exe) in your installed ETL folder.
  • The ETL admin UI can be opened by either using the shortcut on the desktop ("PowerSCADA Expert with Advanced Reports ETL") or  by browsing to the ETL folder and running TacticalSolutionsManager.exe.
  • By default, this folder is found at the following location, but it could have been changed during original installation: C:\Program Files\Schneider Electric\ETL (PowerSCADA)
After opening the ETL admin UI, use the job selection drop down at the top of the window and the Control page to stop all ETL job services associated with this ETL installation.
  • Select a job in the drop down that has an associated windows service.
  • Press the Control button.
  • Press the Stop button to stop the service.  Note: if the Stop button is not enabled, the selected job does not have a windows service that is currently running.
  • Press the OK button to return the main form.
Repeat the four steps above for each job with an associated windows service.

2. Backup the current ETL root folder, and then copy/paste the files from the hotfix zip file into the ETL root folder.
  • Open the ETL root folder in Windows Explorer.
  • Create a backup of the entire ETL root folder and place the backup in a separate location by copying/pasting the files included in this hotfix (attached below) into the ETL root folder.
  • Re-open the ETL admin UI.
Note: if you do not see the CSV Extract Task in the ETL UI after deploying the hotfix, it may be because of the following scenario.

The dll files that make up the hotfix may have been "blocked" by Windows because they came from the internet. This is a common issue for people downloading files from the Internet.  If this is the case, try the following:
  • Close the ETL UI if it is open.
  • You must "unblock" each dll file. To unblock it, browse to the folder containing the files in Windows Explorer.  Open the file's properties (e.g., right-click and select Properties) and then press the Unblock button.
  • Click on the OK button and try again. Open the ETL UI and the CSV Extract Task should now show up.
3. (Optional) - Use ETL's "Run once" feature to run your job a single time and confirm the hotfix was applied as expected.
This step is optional, but it is often useful to see the job run a single time successfully before restarting the windows service associated with the job.

To run a job a single time:
  • Select the job in the drop down at the top of the ETL admin UI.
  • Click the Control button.
  • Click the "Run Once" button.
  • Let the job run to completion, and note the job run completion dialog.
  • When the job finishes, the UI will show an overall 'success' or 'failure' message and will provide a link to the log folder.
  • Open the log folder, and examine the error.log file in a text editor.
  • The newest entries appear at the bottom of this file.
The newest entry should look similar to the following:

[Job Logger Started]
[Job Logger Finished]

Any errors during the run will show up between the 'started' and 'finished' tags.

4. Restart the windows services that were stopped in step 1 above.
To resume the ETL services that were stopped earlier, perform the following:

Use the Control page and click on the play button to start any jobs that were stopped earlier.
  • Select a job in the drop down that you wish to run as a windows service.
  • Press the Control button.
  • Press the Play button to resume the job's service.

Schneider Electric Hong Kong

Attachment(s)
ETL PowerSCADA v1.4 Hotfix 72102.zip [459.33 KB]
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