{}

Our Brands

Impact-Company-Logo-English Black-01-177x54

Welcome to the Schneider Electric Website

Welcome to our website.
Search FAQs
Upgrade of Power Monitoring Expert (PME) 8.x to 8.2 fails with RegBrick_x86 error
Issue
When running the installation utility to upgrade Power Monitoring Expert 8.0 or 8.1 to 8.2, the installation will stop on the copying files section with a warning:
"The feature you are trying to use is on a network resource that is unavailable."



When the user manually selects the file via browse the next error is that the file is not a valid installation package for the product.


Product Line
Power Monitoring Expert 8.x

Cause
This problem is a result of RegBrick_x86.msi being detected as a Trojan by some anti-virus software, McAfee for sure, and possibly other anti-virus packages.
When PME is upgraded, the installer tries to uninstall the old msi packages prior to installing the new ones. Since RegBrick_x86.msi cannot be found where expected, you are prompted to find it manually.

Resolution
Cancel the PME installation.
Uninstall RegBrick_x86.msi via Microsoft 'Program Install and Uninstall Troubleshooter'

1.)  Browse to the Microsoft link below:
https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed
2.)  Download the 'Program Install and Uninstall Troubleshooter' tool and save it locally.
3.)  Run the tool and choose 'RegBrick_x86' from the list of programs that will be presented
4.)  Then click on 'Yes, try uninstall'
5.)  Once this has been done, begin the PME installation utility again

Schneider Electric Hong Kong

Explore more
Range:
Articles that might be helpful Users group

Discuss this topic with experts

Visit our Community for first-hand insights from experts and peers on this topic and more.
Explore more
Range: