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PME Web Applications trends tab shows "waiting for initial data"

Issue
After upgrading PME, the trends tab in web applications shows "waiting for initial data" forever and will not populate with data from meters.

Product line
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024

Cause
There is a problem with the Internet Information Services (IIS) configuration files and they will need to be manually deleted.

Environment
PME web applications

Resolution
First check to see if there is real time data for the device in question. If there is no real time data available, then trends will display "waiting for initial data". Once this is checked, follow the steps below to resolve this issue.

  1. Uninstall IIS
  2. After un-installation of IIS, Windows Process Activation Service (WAS) will also need to be uninstalled
  3. Then delete the files or rename the folder for "C:\inetpub" and "C:\Windows\System32\inetsrv"
  4. To reinstall IIS, just follow the same steps: Install IIS as well as WAS
  5. Next, run a reconfigure of the PME software
  6. Re-install the security certificate for web applications (if there was a certificate to begin with)

A detailed guide showing how to uninstall IIS and WAS can be found HERE.
A detailed guide showing how to install IIS and WAS can be found HERE.

Schneider Electric Hong Kong

PME Web Applications trends tab shows "waiting for initial data"

Issue
After upgrading PME, the trends tab in web applications shows "waiting for initial data" forever and will not populate with data from meters. 

Product line
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024

Cause 
There is a problem with the Internet Information Services (IIS) configuration files and they will need to be manually deleted. 

Environment 
PME web applications

Resolution
First check to see if there is real time data for the device in question. If there is no real time data available, then trends will display "waiting for initial data". Once this is checked, follow the steps below to resolve this issue.

  1. Uninstall IIS
  2. After un-installation of IIS, Windows Process Activation Service (WAS) will also need to be uninstalled
  3. Then delete the files or rename the folder for "C:\inetpub" and "C:\Windows\System32\inetsrv"
  4. To reinstall IIS, just follow the same steps: Install IIS as well as WAS
  5. Next, run a reconfigure of the PME software
  6. Re-install the security certificate for web applications (if there was a certificate to begin with)

A detailed guide showing how to uninstall IIS and WAS can be found HERE.
A detailed guide showing how to install IIS and WAS can be found HERE.

Schneider Electric Hong Kong

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