{}

Our Brands

Impact-Company-Logo-English Black-01-177x54

Welcome to the Schneider Electric Website

Welcome to our website.

Search FAQs

Is it possible to clear the contents of the ION_SystemLog database?

Issue:
A customer would like to clear the contents of the ION_SystemLog database because it contains a large number of unwanted events.

Product Line:
Power Monitoring Expert 8.x
Power Monitoring Expert 9.x
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023

Environment:
ION_SystemLog database

Cause:
A large number of service or system events can cause the SystemLog database to grow in size.

Resolution:
The cause of a large number of system or service events should be identified and corrected prior to performing this procedure.

** Warning: Changes made to the PME databases can leave the system inoperable and require restoration from recent backups or reinstallation.  The following procedure assumes recent database backups are available and the user is familiar with SQL Management Studio and PME. **

The Query below can be used in a system to purge the contents of ION_SystemLog starting with a blank database.

USE [ION_SystemLog]

TRUNCATE TABLE Diagnostic
TRUNCATE TABLE EventID
TRUNCATE TABLE EventException

-- Delete all records
DELETE FROM Event
-- Set current ID to "1"
-- If the table already contains data, use "0"
DBCC CHECKIDENT (Event, RESEED, 0)

Schneider Electric Indonesia

Explore more
Product:
PMEPME4DC
Explore more
Product:
PMEPME4DC
Users group

Discuss this topic with experts

Visit our Community for first-hand insights from experts and peers on this topic and more.