Issue
Understanding the role of the 'IPUpdate' log file
Product Line
ION Setup 3.0
Environment
ION Setup
Cause
Understanding the role of the 'IPUpdate' log file
Product Line
ION Setup 3.0
Environment
ION Setup
Cause
This log file may be used for troubleshooting if a user loses the meter's IP address and is no longer able to connect to it.
Resolution
The IPUpdate log file is used to aid with troubleshooting while attempting re-establish communication to a device where an IP address is not easily recoverable (Eg. TRAN unit or a device in a remote location) or has been incorrectly programmed.
The file may be found in the following directory: C:\ProgramData\Schneider Electric\ION Setup
Prior to sending any changes to the meter, ION Setup will record pertinent IP information including IPv6 link local information.
This allows the user to troubleshoot communication to the device by attempting to browse to the meter's webpage and/or reading Modbus registers. Please note that the meter may have to be isolated from the network and connected directly to the computer. The PC will need to be assigned a static IP address. Please refer to FA221245 for further detail.
The IP Setup Wizard's role is to detect instances where a duplicate IP address or the selected DNS name already exists. The wizard allows the user to bypass the long delay in changing the IP address parameter and attempt to return to the device properties (in ION Setup) in order to enter new IP address information. It's primary objective is to ensure that the user has a functioning connection to the device prior to leaving the reconnection dialog.
Example of IPUpdate log file:
Failed Attempt
IP change started at: Tuesday, November 22, 2016 7:57:53 AM
Existing device connection IP: 10.168.64.180
Device MAC address: 006078045943
IPv4 Address: 10.168.64.186
IPv6 Address: None
IPv6 link local address: fe80::260:78ff:fe04:5943
IPv6 global address: None
FQDN: PM8000_045943.
Waiting on device networking restart...
Checking IP: 10.168.64.186
Transmitting ICMP ping
ICMP Ping response received
Attempting to connect to device using 10.168.64.186...
Device connection successful
Present IPv4 address: 10.168.64.186
Present IPv6 address: None
Checking IP: 10.168.64.180
Transmitting ICMP ping
ICMP Ping timeout
Transmitting ICMP ping
ICMP Ping timeout
Transmitting ICMP ping
ICMP Ping timeout
Transmitting ICMP ping
ICMP Ping timeout
Transmitting ICMP ping
ICMP Ping timeout
Transmitting ICMP ping
ICMP Ping timeout
Transmitting ICMP ping
ICMP Ping timeout
Transmitting ICMP ping
Unable to connect to device
Successful Attempt
IP change started at: Monday, February 20, 2017 2:53:28 PM
Existing device connection IP: 10.168.64.180
Device MAC address: 006078045943
IPv4 Address: 10.168.64.188
IPv6 Address: None
IPv6 link local address: fe80::260:78ff:fe04:5943
IPv6 global address: None
FQDN: TechPubs_PM8000_RLS_021
Waiting on device networking restart...
9 seconds remaining...
8 seconds remaining...
7 seconds remaining...
6 seconds remaining...
5 seconds remaining...
4 seconds remaining...
3 seconds remaining...
2 seconds remaining...
1 seconds remaining...
0 seconds remaining...
Checking IP: 10.168.64.188
Transmitting ICMP ping
ICMP Ping response received
Attempting to connect to device using 10.168.64.188...
Device connection successful
Present IPv4 address: 10.168.64.188
Present IPv6 address: None
Resolution
The IPUpdate log file is used to aid with troubleshooting while attempting re-establish communication to a device where an IP address is not easily recoverable (Eg. TRAN unit or a device in a remote location) or has been incorrectly programmed.
The file may be found in the following directory: C:\ProgramData\Schneider Electric\ION Setup
Prior to sending any changes to the meter, ION Setup will record pertinent IP information including IPv6 link local information.
This allows the user to troubleshoot communication to the device by attempting to browse to the meter's webpage and/or reading Modbus registers. Please note that the meter may have to be isolated from the network and connected directly to the computer. The PC will need to be assigned a static IP address. Please refer to FA221245 for further detail.
The IP Setup Wizard's role is to detect instances where a duplicate IP address or the selected DNS name already exists. The wizard allows the user to bypass the long delay in changing the IP address parameter and attempt to return to the device properties (in ION Setup) in order to enter new IP address information. It's primary objective is to ensure that the user has a functioning connection to the device prior to leaving the reconnection dialog.
Example of IPUpdate log file:
Failed Attempt
IP change started at: Tuesday, November 22, 2016 7:57:53 AM
Existing device connection IP: 10.168.64.180
Device MAC address: 006078045943
IPv4 Address: 10.168.64.186
IPv6 Address: None
IPv6 link local address: fe80::260:78ff:fe04:5943
IPv6 global address: None
FQDN: PM8000_045943.
Waiting on device networking restart...
Checking IP: 10.168.64.186
Transmitting ICMP ping
ICMP Ping response received
Attempting to connect to device using 10.168.64.186...
Device connection successful
Present IPv4 address: 10.168.64.186
Present IPv6 address: None
Checking IP: 10.168.64.180
Transmitting ICMP ping
ICMP Ping timeout
Transmitting ICMP ping
ICMP Ping timeout
Transmitting ICMP ping
ICMP Ping timeout
Transmitting ICMP ping
ICMP Ping timeout
Transmitting ICMP ping
ICMP Ping timeout
Transmitting ICMP ping
ICMP Ping timeout
Transmitting ICMP ping
ICMP Ping timeout
Transmitting ICMP ping
Unable to connect to device
Successful Attempt
IP change started at: Monday, February 20, 2017 2:53:28 PM
Existing device connection IP: 10.168.64.180
Device MAC address: 006078045943
IPv4 Address: 10.168.64.188
IPv6 Address: None
IPv6 link local address: fe80::260:78ff:fe04:5943
IPv6 global address: None
FQDN: TechPubs_PM8000_RLS_021
Waiting on device networking restart...
9 seconds remaining...
8 seconds remaining...
7 seconds remaining...
6 seconds remaining...
5 seconds remaining...
4 seconds remaining...
3 seconds remaining...
2 seconds remaining...
1 seconds remaining...
0 seconds remaining...
Checking IP: 10.168.64.188
Transmitting ICMP ping
ICMP Ping response received
Attempting to connect to device using 10.168.64.188...
Device connection successful
Present IPv4 address: 10.168.64.188
Present IPv6 address: None