{}

המותגים שלנו

Impact-Company-Logo-English Black-01-177x54

ברוכים הבאים לאתר האינטרנט של שניידר אלקטריק

ברוכים הבאים לאתר שלנו.
שאלות נפוצות
Video: Troubleshooting no communication between UPS and PowerChute Business Edition or PowerChute Serial Shutdown

Article available in these languages: Spanish, Russian

Issue:
No Communication with UPS

Product Line:
PowerChute Business Edition
PowerChute Serial Shutdown

Environment:
All supported OS

Cause:
There are many possible causes. See resolution/troubleshooting for list.

Resolution:
Troubleshooting Communications on Windows:

​1.     Check that the PowerChute Business Edition Agent service is running, named "APC PBE Agent." To verify the service is running, open a command prompt as an administrator and enter the command sc query apcpbeagent
command prompt check service status
2.     If you are using serial communications, check a) that you are using the serial cable that came with the UPS and b) that it connects the serial port on the UPS to the serial port on your computer.
3.     If you are using USB communications, make sure that the USB cable that came with the UPS is connected from the USB port on the UPS to the USB port on your computer.
Note: The serial communications cable is not a standard RS-232 cable and differs depending on the UPS type. Please refer to the table below. For USB communications, the cable must be USB-IF certified.

For supported Smart-UPS and Easy-UPS with PowerChute Agent and the correct cable see Schneider Electric FAQ FA163632
What communications cable is needed with my Smart-UPS and Easy-UPS with PowerChute Agent?

For supported Back-UPS with PowerChute Serial Shutdown see Schneider Electric FAQ000237492
What communications cable is needed with my Back-UPS and PowerChute Serial Shutdown?

4. With the correct cable attached, stop and restart the PowerChute Business Edition Agent service, "APC PBE Agent." To stop and restart the service open a command prompt as an administrator and enter the command sc stop  apcpbeagent Once stopped enter sc start apcpbeagent

Command prompt stop-start service

5. Make sure that PowerChute Business Edition is configured to use the correct communication port when communicating via the Serial port.

NOTE: The communication port is no longer configurable within the Agent in v9.5 and above. If you wish to change from a USB to a serial port, you must re-install the PowerChute Business Edition Agent.

Troubleshooting Windows USB Communications

1.     Go to the Windows Control Panel - All Control Panel Items - Device Manager
2.     From Device Manager, select Batteries. You should see the HID UPS Battery.
If the HID UPS Battery driver does not load automatically when the USB cable is connected to the UPS

  • Open C:\Windows\System32\drivers
  • Verify that hidclass.sys, hidparse.sys, and hidusb.sys are available.
  • hidclass.sys, hidparse.sys, and hidusb.sys are included with the Windows OS. You will need to install them via the Windows OS install media if they are missing from the system.
  • Verify that apcups.inf was installed properly during the PowerChute installation

Note: If configuring for native shutdown via Control Panel - Power Options, the driver should be HID UPS Battery. If PowerChute had previously been install, the drive would be APC UPS.

3.     From the Device Manager, select Human Interface Devices (HID). You should see a driver called American Power Conversion USB UPS. If either HID or this driver does not display, proceed with the steps below.
4.     Ensure the USB port is enabled in your computer BIOS. Consult your computer documentation for details on how to enable the USB Port.
5.     If your installation includes a USB hub (a device that multiplies the number of USB ports available) and the UPS is plugged into it, check that the hub is receiving power. Check your hub's manual to learn whether the hub should be powered with an AC/DC adapter.
Note: APC recommends that the UPS USB cable be plugged into the PC's USB port directly, not into a USB hub for optimum performance.
6.     Ensure that the USB cable connected to the UPS is the last in the chain (downstream). Ensure all other USB devices upstream from your APC UPS have communication. If an upstream device is not communicating, any downstream device may not communicate. Remove the device that is not communicating and see if that has any effect.
7.     You can review all connected USB devices Using a freeware utility such as USBDeview.exe. See Schneider Electric FAQ283181 Video: How to verify USB communications between UPS and Windows OS using UsbDeview.exe
8.     If the USB drivers have loaded properly and USBDeview.exe can discover the UPS yet PowerChute cannot discover the UPS, uninstall PowerChute, and reset the communications bus.
a. For an SMT, SMTL, or SMX model UPS, on the display interface, hold the UP and DOWN buttons simultaneously for 10 - 12 seconds. The display flashes to indicate that the network interface has restarted.
b. To reset the communications bus of an SMC model UPS, on the display interface, hold the MUTE and MENU buttons simultaneously for 10 - 12 seconds. The display flashes to indicate that the network interface has restarted.
c. To reset the communications bus of an SCL model UPS, insert paperclip into the reset hole on the rear of the UPS.
d. For all other Smart-UPS, power down all equipment connected to the UPS, and cold start/brain-dead the UPS. For assistance with performing the cold start/brain dead procedure, see Schneider Electric Video: How to perform a cold start and brain dead on Smart-UPS.
9. On SMT and SMTL model UPS, disable Green mode. To disable Green mode from the UPS LCD panel go to Configuration - Green Mode
10. Disable Selective Suspend Settings within the OS power options. To disable USB selective suspend open the control panel. Go to power options, select change plan settings, change advanced power settings, USB settings
USB Selective Suspend Settings
11.   After resetting the communications bus or restarting the UPS, reinstall PowerChute. When reinstalling, when asked, "Would you like to automatically search all communication ports for a UPS?" select No. In the next screen, when asked to "Select your UPS Model:" from the drop-down select "Other Type-A" if your UPS model is an SMT, SMX, SMC, SMTL, SRT, SCL. If the UPS model is SUA, select "Other Type-B". In the next screen, when asked, select USB as the com port.

Select UPS Model


Select USB Port
NOTE: For step 11 to work, PowerChute would need to have been previously installed on the system. If not the required APC UPS driver will not be available. See Schneider Electric FAQ Video: How to restore APC PowerChute device drivers on Windows? for assistance with loading the APC UPS driver.

Troubleshooting Windows Serial Communications
Try debugging the COM port with a tool like PuTTY.
For Smart-UPS models SU and SUA. See the "Checking UPS Communications on Windows" section of the attached PowerChute Business Edition Installation Guide for more information.

When configuring PowerChute Agent to communicate using simple signaling the UPS will not be discovered automatically. When running the installer, the UPS must be added manually.

NOTE: For Smart-UPS models SMT, SMTL, SMX, SMC, SCL, SRC, SURTD, and all SmartConnect Smart-UPS models, it is not possible to test serial com using PuTTY or other serial comm tools.


Additional Windows Troubleshooting Information
1.     After following the steps outlined in the Troubleshooting sections above, stop and restart the PowerChute Business Edition Agent. If the system cannot communicate, proceed to the next step.
2.     If you have a SmartSlot accessory connected to the UPS, check that it is configured correctly. More information regarding these accessories is available at http://www.apc.com/products/
3.     If you still have not established communication, try using another communications (Serial/USB) cable if one is available.
If you have tried all of the techniques above but have still not established communication, contact Schneider Electric Technical Support at http://www.apc.com/support/ for troubleshooting help.

Troubleshooting Communications on Linux
Serial Comm:
1.   Make sure that the serial cable that came with the UPS is connected from the serial port on the UPS to the serial port on your computer.
2.   Stop and start the PowerChute Agent. If the Agent process is not running: start and stop it by entering the following commands in a command prompt:
# /Linux/
# /etc/init.d/PBEAgent start
# /etc/init.d/PBEAgent stop
3.   Try debugging the COM port with a tool like PuTTY - using 2400 as the baud rate for Smart-UPS models SU, and SUA. See the "Checking UPS Communications on Windows" section of the PowerChute Business Edition Installation Guide for more information.

NOTE: For Smart-UPS models SMT, SMX, SMC, SURTD it is not possible to test serial com using PuTTY or other like tools.

USB Comm:
USB communications is supported with PowerChute Agent 9.5 running Redhat Linux and starting with version 10 the Agent is supported on SUSE Linux. See the PowerChute Agent Operating System, Process and JRE Compatibility Chart available at https://www.apc.com/us/en/product-range/61932-powerchute-business-edition/#documents to verify support.
To test the USB ports run the command usb-devices to see a list of connected USB devices. If the command is not present in the OS contact the OS provider support for assistance.

שניידר אלקטריק ישראל

גלה עוד
טווח:
מאמרים שעשויים להיות מועילים
גלה עוד
טווח: