Monitoring an APC device with StruxureWare Data Center Expert using SNMPv3 after it was discovered using SNMPv1
Product Line:
StruxureWare Data Center Expert (DCE)
Environment:
- StruxureWare Data Center Expert (firmware >= 7.0)
- APC Network Management Cards (all versions)
Cause:
Changing monitoring protocol from SNMP version 1 to SNMP version 3.
Resolution:
You can change the protocol the DCE server uses to monitor APC devices discovered as SNMPv1 to SNMPv3.
NOTE: You can change the protocol only on APC SNMPv1 devices that support SNMPv3. For information about whether an APC SNMP device supports SNMPv3, consult the device documentation. Before you begin, it is recommended to view and confirm the devices you want to convert from SNMPv1 to SNMPv3 in the "Device Scan Settings" display, accessed from the SNMP Device Communication Settings option in the Device menu.
1) Open the DCE Client and go to: Device Menu > APC SNMP Device Configuration.
2) Select Standard Device Configuration, then Configure Devices.
3) Select a device you would like to switch to SNMPv3 and then select Retrieve Device Settings.
4) If the device settings pull in, select next. Otherwise, check the Device File Transfer Settings, and then attempt to Retrieve Device Settings again.
5) Check the boxes for the devices you wish to configure for SNMPv3 and select Next.
6) Expand the SNMPv1 Settings section, check the box for Access and set the value to Disabled.
NOTE: Ensure to only check the box for Access and not the other SNMPv1 Settings.
7) Expand the SNMPv3 Settings section, check the box for Access and set the value to Enabled.
8) Expand Authentication options 1-4, check the box for the one you would like to use. Edit the SNMPv3 options.
NOTE: The security settings on some target devices might require setting user passwords, authentication phrases, and encryption phrases manually at the device user interface.
9) Click Finish and a Device Configuration Status pane will come up and show you the status of the configuration change.
NOTE: The configuration status will show as Incomplete Configuration, as DCE is unable to verify the changes due to security reasons. You can view additional details by right-clicking and then selecting Show Configuration Results. An actual value of "Not Supported" means that DCE is unable to verify the changes were successful due to NMC security restrictions.
NOTE: You can verify that the device is now using SNMPv3 by going to: Device > SNMP Device Communication Settings > Device Scan Settings. It has been seen in some instances that DCE may not set the scan settings to the proper protocol (SHA, AES, etc.). This can be corrected manually on this Device Scan Settings page.
It may take up to 15 minutes or more to actually change these settings so you may want to disable off-line alerts while you are attempting this procedure. You may also want to select smaller groups of devices to which you want to push these changes as large configuration pushes can take a great deal more time.