Issue:
When I launch Web Applications, and select 'Log in as Visitor', I see an 'HTTP Error 404.0 -Not Found' error and am unable to log into Web Applications:
Product Line:
Power Monitoring Expert 7.2.x, 8.x
Cause:
IIS is not configured correctly.
Resolution:
When I launch Web Applications, and select 'Log in as Visitor', I see an 'HTTP Error 404.0 -Not Found' error and am unable to log into Web Applications:
Product Line:
Power Monitoring Expert 7.2.x, 8.x
Cause:
IIS is not configured correctly.
Resolution:
- Ensure that the HTTP Redirection feature is installed for IIS.
- On the task bar, click Server Manager.
- In Server Manager, click the Manage menu, and then click Add Roles and Features.
- In the Add Roles and Features wizard, click Next. Select the installation type and click Next. Select the destination server and click Next.
- On the Server Roles page, expand Web Server (IIS), expand Web Server, expand Common HTTP Features, and then select HTTP Redirection. Click Next.
- On the Select features page, click Next.
- On the Confirm installation selections page, click Install.
- On the Results page, click Close.
- Add the following entry to the Web.config file for Application Framework (example Web.config location: "C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\Applications\ApplicationFramework\Web.config"):
<system.webServer>
<modules runAllManagedModulesForAllRequests="true"></modules>
</system.webServer>