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Why does the Com’X Return Modbus Exception 0x0a When Polling the Digital Inputs?
Environment
The environment for this FAQ includes one or more remote Modbus TCP/IP clients such as PME, PSO, or third party application polling the Com’X digital inputs.

Issue

The Com’X periodically returns “Gateway Path Unavailable (0x0a)” exceptions when polling its analog or digital inputs. This happens at the top of each hour and continues for up to 20 seconds. This behavior can cause nuisance alarms and comms failures if the client is not configured to manage the exception.

Root Cause

There is a 10-20 window at the top of each hour where communication to the Com’X Inputs can be delayed due to blocking background applications. The Com’X returns the GATEWAY PATH UNAVAILABLE (0x0a) exception indicating the inability to access the inputs.

Prevention
There is no way to prevent this behavior.

Detection
The issue can be detected by the reply of exception 0x0a when polling the Com’X inputs.

Resolution

  • Remote applications polling the Com’X inputs must be configured to tolerate this behavior by the implementation of retry logic.
  • The combination of retries and time between retries should be configured to span the 20 second period where application is busy, and exceptions are returned.
(Number of retries on exception) * (Time between retries) >> 20 seconds

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