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FAQ 검색
Power Monitoring Expert 8.x - Web Reports stuck on "Please Wait" when selecting a report template
Issue
When loading a report template in webreporter the report template infinitely loops with message "please wait". On further troubleshooting we see the below messages in PME system log.

"Could not load file or assembly "NMathStatsKernel.netmodule" or one of its dependencies. The specified module could not be found."



Product Line
PME8- Base Edition
PME8- HealthCare Edition
PME8- DataCenter Edition
PME8- Buildings Edition

Environment
Webreporter upgrade from SPM7.0.1 or PME7.2.x

Cause
The webreporting tool in SPM7.0.1 or PME7.2.x used "NMath module" in its reporting engine which is no longer used by PME8.

Resolution
*Warning: Take backups of any files prior to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).


To resolve this issue, please follow the below steps:
1. Navigate to the folder "...\Power Monitoring Expert\System\Bin" where PME8 is installed. Move the files that start with "NMath.." (shown in screen shot below) to a different folder.
2. Navigate to the folder  "...\Power Monitoring Expert\Web\Bin" where PME8 is installed. Move the files that start with "NMath.." to a different folder.
3. Perform an iisreset by opening up a command prompt and executing command "iisreset"
4. Restart 3 Application Module services (listed below) which are found in Windows services
a. ApplicationModules CoreServicesHost
b. ApplicationModules DataServicesHost
c. ApplicationModules ProviderEngineHost
5. Reload web applications and confirm webreporter can pull the required report template.

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