{}

브랜드

Impact-Company-Logo-English Black-01-177x54

슈나이더 일렉트릭 코리아 웹사이트에 방문해 주셔서 감사합니다.

슈나이더 일렉트릭 코리아 웹사이트 방문자 분들 모두 환영합니다.
FAQ 검색
Power Monitoring Expert 9.0 - No logged data being uploaded - SystemLog error says - ..'failed to write config info to database because 'Could not find a time zone with the display name: ...'

Issue
After an upgrade to PME 9.0, a pair of errors like the following will appear in the ION_SystemLog every 60 seconds:

Could not finalize recorder Group.Name(4096). (This message has been repeated 0 times.)
0x1000@Group.Name - failed to write config info to database because 'Could not find a time zone with the display name: (UTC-06:00) Central America'. Will retry in the 60s.

No logs from the referenced device will be uploaded after the upgrade

Product Line
Power Monitoring Expert 9.0

Environment
After upgrading from an older PME version to PME 9.0

Cause
The Log Inserter will fail to upload logs when the timezone display name in the Windows Registry does not match the timezone display name for a device in the ION_Data.dbo.Timezone table.

Resolution

*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*​

Before proceeding, shut down the ION Log Inserter service.
You will need to look at the Windows Registry to find the name of the timezone that your device is referencing and then edit the ION_Data database Timezone table so that the name in the database matches the name in the Windows Registry.

1. Start RegEdit and go to "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones\<Your server timezone>" and under that time zone, find the 'Display' value.
2. In SQL Management Studio go to [ION_Data].[dbo].[Timezone] table and look for entries in which the DisplayName column does not match what you see in the Windows Registry
3. Update the timezone display name in [ION_Data].[dbo].[Timezone] to match the registry key
4. Start the ION Log Inserter service and verify that the error is no longer there.

Additional Information
This is most likely to happen when the timezone display name has been localized, for example (UTC-06:00) América Central will appear in the ION_Data Timezone table, but (UTC-06:00) Central America will appear in the Windows Registry.

슈나이더 일렉트릭 Korea

자세히 알아보기
제품군
유용한 문서
자세히 알아보기
제품군