{}

브랜드

Impact-Company-Logo-English Black-01-177x54

슈나이더 일렉트릭 코리아 웹사이트에 방문해 주셔서 감사합니다.

슈나이더 일렉트릭 코리아 웹사이트 방문자 분들 모두 환영합니다.
FAQ 검색
PME2020 - An error occurred while executing command when running Diagnostics Tool
Issue

Issue 1:
When generating a PME Diagnostics, the Output analysis gives multiple errors like:
Executing command: Product and Device Information
An error occurred while executing command [Product and Device Information], see log for details.
Executing Command: SystemLog Events
An error occurred while executing command [SystemLog Events], see log for details.
Executing Command: AppMods Diagnostics
An error occurred while executing command [AppMods Diagnostics], see log for details.
Checking the Diagnostics log located at C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\Diagnostics Tool\Logs, the following error will be logged for all the failed steps:

[08.04.2020 13:56:49] Exception message: Input string was not in a correct format.
[08.04.2020 13:56:49] Stack Trace:    at System.Number.ParseSingle(String value, NumberStyles options, NumberFormatInfo numfmt)
at IONEnterpriseCommands.EnterpriseUtilities.GetConnectionString(String database)
at IONEnterpriseCommands.SystemLogCommand.Execute()
at DiagnosticsTool.DiagnosticsManager.ExecuteCommand(Object command)

Issue 2:
When generating a PME Diagnostics, the Output analysis gives multiple errors like:
Executing command: Product and Device Information
An error occurred while executing command [Product and Device Information], see log for details.

Checking the Diagnostics log located at C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\Diagnostics Tool\Logs, the following error will be logged for all the failed steps:

[08.04.2020 13:56:49] Exception message: "Exception has been thrown by the target of an invocation"

Product Line

Power Monitoring Expert 2020

Environment

Diagnostics Tool

Cause

When the Diagnostics tool is checking PME versions to determine how to connect to the databases, it was not parsing the 9.1 string properly into a number depending on the regional settings of the server ( some separator symbols may vary from culture to culture, like decimal separator for instance).

Resolution

1) Make sure the Diagnostic Tool is closed

2) Go to C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\Diagnostics Tool\Commands

3) Make a copy of IONEnterpriseCommands.dll (in a separate folder)

4) Replace it with the one attached

Additional Information
1) If the tool does not launch after applying the hotfix, make sure to unblock the new dll file.
- Right click > Properties> General tab > at the bottom > Unblock

2) There will be a new release of the tool that will include this hotfix.

슈나이더 일렉트릭 Korea

첨부 파일
DiagnosticsTool-Release.5.1_Hotfix_20105.01.7z [40.28 KB]
자세히 알아보기
제품군
유용한 문서
자세히 알아보기
제품군