Our Brands

Welcome to the Schneider Electric Website

Welcome to our website.
		
How can we help you today?
How to automatically backup a PowerSCADA Expert system

Issue
Automatic backups are required for PowerSCADA Expert

Product Line
PowerSCADA Expert 8.2

Environment
Windows Task Scheduler

Cause
Automatic backups are not natively implemented within PowerSCADA Expert.

Resolution
This attached document includes the tasks required to create automated backups of a PSE system.

You can automate the backing up of PowerSCADA Expert (PSE) to include most of the PSE components that will be required to restore a system. PSE passwords and device profiles cannot be automatically backed up. They must be backed up manually. You can find the required procedure for this process starting on page 9.

.NET 4.5.2 and WMF 5.1 are required in order to run the provided scripts. WMF 5.1 is available as an offline windows update installer.

To automate the PSE backup process:

  1. Create a BackupTasks directory under C:\Program Files (x86)\Schneider Electric\BackupTasks.
  2. In a text editor, open the PSEv9.x_Backup.ps1 (or .txt) script for your version.
  3. Edit the file for your system:
    1. For <$destinationDir>, enter your backup directory location.
    2. If you did not install PSO to the default install location, edit the <$pseBin> and <$pseData> to reflect the installed location path.
  4. Save the file as PSO_Backup.ps1 in the following location: C:\Program Files (x86)\Schneider Electric\BackupTasks
  5. In a text editor, open the Delete_Old_Backups.ps1 (or .txt) script for your version.
  6. Edit the file for your system:
    1. For <$PSEpath>, enter your backup\PSO_Backups directory location.
  7. Save the file as Delete_Old_Backups.ps1 in the following location: C:\Program Files (x86)\Schneider Electric\BackupTasks
  8. Run PowerShell as Administrator and set the execution policy with the following cmdlet: Set-ExecutionPolicy Bypass.  Select “A” to execute all steps of the change. Note: This might be overridden by group policy, but the new scripts seem to work on the server.
  9. Open Windows Task Scheduler create a new task “PSO Backups” under the Schneider Electric folder.

Image1

Set the task to run under NT AUTHORITY/SYSTEM or NT AUTHORITY\LOCAL SERVICE (use SYSTEM under advanced selection)
Image2
Set the task to run under NT AUTHORITY/SYSTEM or NT AUTHORITY\LOCAL SERVICE (use SYSTEM under advanced selection)
Click the Change User or Group… button. Type “system” in the “Enter the object name” area. The “From this location” selection should be set to the local server.
Image3
Click Check Names
Image4
Click OK.
Image5

  1. Set a trigger to run once a week. We have chosen Sunday at 1am in the past.

Image6

  1. Define the new action: Note: Please verify these file locations. The text of the program/script and argument can be found in the Scheduled task – Program and Argument Text.txt file .
    1. For Action, click Start a program.
    2. In Program/script, enter the following: C:\Windows\syswow64\WindowsPowerShell\v1.0\powershell.exe
    3. In Add arguments, enter the following:

-noninteractive -nologo -file "C:\Program Files (x86)\Schneider Electric\BackupTasks\PSOv9.0_Backup.ps1"
Tip: You can manually run the scheduled task to confirm that it copied the PSO components to your backup location. Doing so will also help you verify whether you can access the backup
location. This process can take 2 hours or more for 40GB of files.
Image10

  1. Hit OK to save the Scheduled Task.
  2. Open Windows Task Scheduler create a second new task “PSO_Delete_Old_Backups” under the Schneider Electric folder.


Set the task to run under NT AUTHORITY/SYSTEM or SYSTEM . (see above)

  1. Set a trigger to run once a week. We have chosen Sunday at 1am in the past.

  1. Define the new action: Note: Please verify these file locations. The text of the program/script and argument can be found in the Scheduled task – Program and Argument Text.txt file .
    1. For Action, click Start a program.
    2. In Program/script, enter the following: C:\Windows\syswow64\WindowsPowerShell\v1.0\powershell.exe
    3. In Add arguments, enter the following:

-noninteractive -nologo -file "C:\Program Files (x86)\Schneider Electric\BackupTasks\Delete_Old_Backups.ps1"

  1. Hit OK to save the Scheduled Task.



Note: Some procedures in this document cite scripts you can use to automate the backup and restore process. These scripts are included in the below as .txt files. When downloading these files they need to be saved as .ps1 files to make them power shell scripts. Only download the script for the respective version of PSE (i.e. 8.1 or 8.2 not both)

Schneider Electric Saudi Arabia

Attachment(s)
PSOv9.0_Backup.txt [3.81 KB]
PSEv8.1_Backup.txt [2.57 KB]
Scheduled task - Program and Argument Text.txt [485 Bytes]
PSOv9_Restore.txt [2.41 KB]
PSEv8.1_Restore.txt [2.28 KB]
Delete_Old_Backups.txt [772 Bytes]
Explore more
Range:
Users group

Discuss this topic with experts

Visit our Community for first-hand insights from experts and peers on this topic and more.
Explore more
Range:

Need help?

  • Product Selector

    Quickly and easily find the right products and accessories for your applications.

  • Get a Quote

    Start your sales enquiry online and an expert will connect with you.

  • Where to buy?

    Easily find the nearest Schneider Electric distributor in your location.

  • Help Centre

    Find support resources for all your needs, in one place.

1. What is field service management?

All the jobs performed in the field and not inside a company's premises are called field services. It requires skilled professionals at the customers' location to perform functions such as installation, repairs, and maintenance. We understand how daunting it can be to constantly supervise these services, and therefore, we offer you our assistance in the domain via field service management. Schneider Electric's expert professionals ensure a smooth installation, enhanced equipment life, and uninterrupted business continuity while optimizing the organization's operations and equipment.

2. What is the importance of field management?

In simple terms, all the jobs that are carried out on the field and not inside the company's premises are called field services. It requires the supervision of skilled professionals at the customer's location for performing technical functions like servicing, maintenance, installation, and repairs. We at Schneider Electric India understand how exhausting it can be to constantly supervise deskless services on an everyday basis. Therefore, we offer you our assistance in the domain by extending our exceptional field service management. Our learned professionals ensure a smooth installation, enhanced equipment life and uninterrupted business continuity while effectively optimizing organizations' electrical instruments and operations.

3. What are the uses of field management services?

Field management services carry the potential to reduce human effort and increase employee productivity by a drastic rate. An array of field service management software solutions digitally track and analyze crucial data like field notes, expenses, work completion time etc., improving task visibility which leads to error-free business decisions. In addition, field management services effectively bring down overhead costs by improving planning, inventory management, scheduling, and upgrading ways of communication. Schneider Electric India is a leading field management service provider that extends expertise in delivering resilient and technically advanced solutions and services for industrial automation, building management and electrical distribution combined with cooling services and critical power that boosts operational efficiency and asset reliability.

4. Who uses Field services?

As mentioned above, field services can be referred to as the process of deploying skilled resources, assets, and workers to offsite locations. Therefore, several businesses and industries can benefit by employing quality field management services like fire and life safety, medical device enterprises, communication services companies, facility management industry, industrial equipment enterprises, construction industry and more.

At Schneider Electric India, we ensure that all our customers receive the assistance of our highly skilled professionals who are professionally trained to carry out various crucial offsite tasks in the most efficient and optimized manner while delivering quality results.
  • Product Documentation
  • Software Downloads
  • Product Selector
  • Product Substitution and Replacement
  • Help and Contact Centre
  • Find our Offices
  • Get a Quote
  • Where to buy
  • Careers
  • Company Profile
  • Report a misconduct
  • Accessibility
  • Newsroom
  • Investors
  • EcoStruxure
  • Job Search
  • Blog
  • Privacy Policy
  • Cookie Notice
  • Terms of use
  • Change your cookie settings
Your browser is out of date and has known security issues.

It also may not display all features of this website or other websites.

Please upgrade your browser to access all of the features of this website.

Latest version for Google Chrome, Mozilla Firefox or Microsoft Edgeis recommended for optimal functionality.