Issue
Try to use Management Console's "Deactivate Alarms" feature, as a non-admin user, to deactivate one or more of those active alarms and the following error will appear:
"an unexpected condition was encountered while initializing the AlarmInactivator: Write to Primary data queue failed.."
Product Line
Power Monitoring Expert 9.0
Envorinment
Management Console - "Deactivate Alarm" feature
Cause
PME's MQ setup uses the "Everyone" bucket for permissions and permissions set for the "Everyone" group DO NOT APPLY to domain users by default.
Resolution
Resolution 1:
Run Management Console "As Administrator" (i.e. the right-click menu in Windows).
Resolution 2:
1. Log in as administrator of the server
2. Open the Windows Start menu and search "Computer Management"
3. Open Computer Management then expand Services and Applications > Message Queues
4. Check permissions for all of the private queues by right-clicking on each of them and selecting Properties > Security
- List of private queues to check:
- cloudagent_control
- cloudagent_data
- logsubsystemprimaryrouter_control
- logsubsystemprimaryrouter_data
- logsubsystemsecondaryrouter_control
- logsubsystemsecondaryrouter_data
- Make sure each of the queues listed above have the following permissions:
- "Everyone" group has access to allow:
- Get Properties
- Get Permissions
- Send Message
- "Administrators" group should have full access to the queue
- "ANONYMOUS LOGON" Group should only have access to:
- Send Message
- "Everyone" group has access to allow:
- Get Properties
- Get Permissions
- Send Message