Issue
An issue has been identified with AP79XX series Switched Rack PDU users who enable the global outlet group functionality. If the user has AP79XX series units on the same subnet with AP89XX or AP86XX series Switched Rack PDUs that also have the global outlet group functionality enabled and both are using the same multicast IP range value, the AP79XX series will fall into a reboot loop and after six tries, stop booting. This results in both of the following symptoms, depending on how you normally access the PDU.
Web Interface:User will receive the following message or similar after the reboot loop has stopped
Error: The application was not able to load.
You are attempting to access an APC device.
There was a problem loading the application. Please login to the device via telnet for more details.
Telnet/SSH/Local Console: User will notice Stat section indicates A! or A-.
American Power Conversion Network Management Card AOS v3.7.4
(c) Copyright 2009 All Rights Reserved Rack PDU APP v3.7.4
-------------------------------------------------------------------------------
Name : RackPDU Date : 06/26/2014
Contact : Unknown Time : 15:34:50
Location : Unknown User : Administrator
Up Time : 8 Days 1 Hour 47 Minutes Stat : P+ N+ A-
Product Line
- Rack Power Distribution
- AP79XX Switched Rack PDU
- AP89XX Switched Rack PDU 2G
- AP86XX Switched with Metering By Outlet
Environment
- Users utilizing global outlet group/global outlet groups via network
- Users with both AP79XX and AP89XX and/or AP86XX PDUs in their environment
- AP79XX series v3.X.X firmware
- AP89XX and AP86XX firmware - all versions
Cause
This is a firmware bug on the AP79XX series Switched Rack PDUs. The following criteria must be met in order for the issue to occur:
- Global outlet group configuration on both generations of Switched Rack PDU are enabled.
- Both generations/groups of Switched Rack PDUs are utilizing the same Multicast IP range.
- Both generations/groups of Switched Rack PDUs are on the same subnet/network.
Resolution
- Verify this is your issue by understanding if you have both generations of Switched Rack PDU active in your environment.
- Next, confirm what you did previously before the condition on the AP79XX occurred. (For example, similar error messages can be provided by AP79XX when a firmware upgrade has failed.) Verify it is feasible global outlet groups were recently enabled or you added a different generation of Rack PDU to your subnet with this feature enabled - it is disabled by default.
- Access to the current configuration on the AP79XX via config.ini file or Telnet/SSH/Local console menu will be unavailable. There are few options.
- Check AP89XX and AP86XX Outlet Group configuration to verify if outlet groups are enabled.
- If so, consider disabling them temporarily, which requires the PDU to reboot.
- After completing the previous step, reboot the AP79XX series Rack PDU which will restart the PDU's attempts to boot properly.
- As long as there is no traffic from the AP89XX or AP86XX series units, the AP79XX should boot properly.
- If the AP79XX series boots properly, you should change the Multicast IP range to be different from the AP89XX and AP86XX series.
- Alternatively, the user can reset the AP79XX series PDU to default (excluding TCP/IP is OK) which will disable global outlet groups.
- Then, reconfigure the PDU and make arrangements to select a different, unique Multicast IP range for each series of Rack PDU, and also each individual PDU group who share outlets.
- Check AP89XX and AP86XX Outlet Group configuration to verify if outlet groups are enabled.
AP79XX series
Note: These methods will be unavailable or missing if your PDU is already experiencing this issue. Depending on your environment, you'll need to either work around the issue with the AP79XX series as noted above or verify on the AP89XX or AP86XX series and modify there to temporarily disable. Then, reboot the AP79XX series after the AP89XX or AP86XX traffic is no longer present or is configured on a different Multicast IP range.
- Web Interface - Navigate to Device Manager tab, Outlet Groups->Group Configuration. There is a drop down list here that says Device Level Group: Enabled or disabled. If enabled, you may be experiencing this issue.
- Config.ini configuration file - Under the [OutletGroup] section, look for the following values below. OutletGroupMembership=Enabled indicates the feature is enabled.
; Configure an Outlet Group on the RackPDU.
; Format: OutletGroup# = Outlets[], Name
; Outlets: Outlet numbers to be grouped: Outlets[1,2,3...]
; Note: Global outlets are indicated by an '*' after the
; outlet number (e.g. Outlets[1*,2,3])
; Name: Outlet Group text description
OutletGroupMembership=Enabled
OutletGroupMulticastName=McastName
OutletGroupMulticastIPAddr=224.0.0.100
- Web Interface
- v5.X.X firmware - Navigate to Device Manager tab, Outlet Groups->Group Configuration. There is a drop down list here that says Device Level Group and it has a few different options. Earlier versions say Enabled or Disabled. Enabled or Enabled via Network means that the feature is enabled.
- v6.X.X firmware - Navigate to Configuration->RPDU->Switched Outlet->Outlet Group Settings. There is a drop down list here that says Device Level Group and it has a few different options. Enabled via Network means that the feature is enabled.
- Config.ini configuration file
- v5.1.0, 5.1.1, 5.1.2 firmware - Under the [OutletGroup] section, look for the following values below. OutletGroupMembership=Enabled indicates the feature is enabled.
; Configure an Outlet Group on the RackPDU.
; Format: OutletGroup# = Outlets[], Name
; Outlets: Outlet numbers to be grouped: Outlets[1,2,3...]
; Note: Global outlets are indicated by an '*' after the
; outlet number (e.g. Outlets[1*,2,3])
; Name: Outlet Group text description
OutletGroupMembership=Enabled
OutletGroupMulticastName=McastName
OutletGroupMulticastIPAddr=224.0.0.100
- v5.1.6, v6.X.X firmware - Under the [Outlet] section, look for the following value below.
OUTLET_GROUPS_ENABLE_A=Enabled
MULTICAST_NAME_A=McastName
MULTICAST_IP_A=224.0.0.100