Issue
The user would like to check the report subscription queue to identify any backed-up reports.
Product line
Power Monitoring Expert up to Version 2023
Environment
SQL Server Management studio
Cause
The RPT_SubscriptionEvent table within the ION_Nework contains a list of report subscriptions that will be dealt with by the Report Subscription Services. Entries should get deleted from the table as soon as they've been processed. If there are multiple rows in this table at one time, it might indicate a backup in servicing subscriptions. If you restart the system and there are records in that table, the Report Subscription Service will start running them all until they're all finished; which might be an undesirable outcome. The report scheduler is responsible for inserting the report subscriptions in the table mentioned earlier. PME uses 2 different types of schedulers depending on the SQL server edition installed. If using SQL Server Standard Edition, Report subscriptions are scheduled by SQL Server Agent jobs and it would be worthwhile checking the SQL server event log to troubleshoot report subscriptions. If SQL server express edition is installed, PME's report subscription utilizes the Report subscription's internal scheduler. Below is a screenshot of a report subscription in the subscription queue :
Resolution
To view the table:
1- Launch SQL Server management studio and connect to PME's database instance. You can either use Windows authentication or SQL server authentication to log in
2- Click on the new query and then write the following query:
Use ION_Network
Select * from RPT_SubscriptionEvent
3- Execute the query above by clicking on the execute button
4- the table below is a screenshot of a report subscription in the subscription queue.
To view the current SQL Jobs and related error logs:
1- In SQL Server Management studio's Object Explorer, click the plus sign to expand SQL Server Agent.
2- To view current Job activities, click the plus sign to expand jobs and then click on Job Activity Monitor.
3- To view SQL Server Agent error logs, expand the error logs and click on one of the logs as shown below:
The SQL Server Agent jobs log can also be found in the Windows application event log ( can be accessed from the event viewer).
The user would like to check the report subscription queue to identify any backed-up reports.
Product line
Power Monitoring Expert up to Version 2023
Environment
SQL Server Management studio
Cause
The RPT_SubscriptionEvent table within the ION_Nework contains a list of report subscriptions that will be dealt with by the Report Subscription Services. Entries should get deleted from the table as soon as they've been processed. If there are multiple rows in this table at one time, it might indicate a backup in servicing subscriptions. If you restart the system and there are records in that table, the Report Subscription Service will start running them all until they're all finished; which might be an undesirable outcome. The report scheduler is responsible for inserting the report subscriptions in the table mentioned earlier. PME uses 2 different types of schedulers depending on the SQL server edition installed. If using SQL Server Standard Edition, Report subscriptions are scheduled by SQL Server Agent jobs and it would be worthwhile checking the SQL server event log to troubleshoot report subscriptions. If SQL server express edition is installed, PME's report subscription utilizes the Report subscription's internal scheduler. Below is a screenshot of a report subscription in the subscription queue :
Resolution
To view the table:
1- Launch SQL Server management studio and connect to PME's database instance. You can either use Windows authentication or SQL server authentication to log in
2- Click on the new query and then write the following query:
Use ION_Network
Select * from RPT_SubscriptionEvent
3- Execute the query above by clicking on the execute button
4- the table below is a screenshot of a report subscription in the subscription queue.
To view the current SQL Jobs and related error logs:
1- In SQL Server Management studio's Object Explorer, click the plus sign to expand SQL Server Agent.
2- To view current Job activities, click the plus sign to expand jobs and then click on Job Activity Monitor.
3- To view SQL Server Agent error logs, expand the error logs and click on one of the logs as shown below:
The SQL Server Agent jobs log can also be found in the Windows application event log ( can be accessed from the event viewer).