{}

Våra varumärken

Impact-Company-Logo-English Black-01-177x54

Välkommen till Schneider Electrics webbplats

Välkommen till vår webbplats.

Sök bland vanliga frågor (FAQ)

Power Monitoring Expert (PME) - Reconfigure fails on Create Databases step after a Side-by-Side upgrade. "The database principal owns a schema in the database, and cannot be dropped."

Issue
After writing to the system using the Configuration Manager Tool (CM Tool) during a Side-by-Side (SBS) upgrade, a Reconfigure is necessary for upgrading the database schemas. The Reconfigure fails on the Create Databases step, and there is a message in the ION_Data.log or ION_Network.log file (located in C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\Database\Diagnostic) that says: The database principal owns a schema in the database, and cannot be dropped.

Setup window

Product Line
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023

Environment
PME SBS upgrade

Cause
The error message (seen below) indicates that the software was unable to drop objects that were removed from the database, because the database principal owns a schema in the database.
"Executing post-deployment incremental upgrade script(s) for Schema Version: 13. Current Version: 11.Dropping objects that were removed from the database during this revision - Starting...
Msg 15138, Level 16, State 1, Server PMESERVER, Line 53
The database principal owns a schema in the database, and cannot be dropped."

Resolution #1
The schema causing the issue will have to be deleted manually to fix it. (This may also occur if PME was uninstalled prior to a system upgrade)
To do this:
  1. Open SQL Server Management Studio and connect with valid log-in credentials.
  2. Expand ION_Data > Security > Schemas.
  3. There is a schema called Report that was carried over from an older version of PME.
  4. Delete the Report schema manually by right-clicking and selecting Delete
  5. Confirm that the Report schema is not in ION_Network > Security > Schemas. If it is, repeat step 4.

Schema display


Resolution #2
If the Report schema does not exist, check if one of the other schemas has "Report" as the owner:

  1. Follow steps 1 and 2 of Resolution #1.
  2. Right-click on db_datareader and select "Properties."
  3. Check if the owner is "Report." If yes, change it to "db_datareader."
  4. Follow the above steps for the other schemas. The owner name should be the name of the schema itself.

Schneider Electric Sverige

Utforska mer
Produktfamilj
Utforska mer
Produktfamilj