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SPM - Unable to view Report Subscriptions in the Web Client

Issue

When attempting to modify an existing Report Subscription in the StruxureWare Power Monitoring Web client, the Subscription does not show under the list for the particular report. The Subscription still works but we are unable to view or configure it.


Product Line
StruxureWare Power Monitoring 7.0.x

Environment
SPM Web Application

Cause

If the Report Subscription was created by a user account that has since been removed from the User Manager the Subscription will continue to run, however it will no longer show in the Web client and therefore be un-editable.
Every Report Subscription in the dbo.RPT_Subscription table, is tagged with an Owner ID. This Owner ID corresponds to the UserID from the dbo.Users table, and indicates which user created the Subscription. The stored procedure that retrieves the Subscription list for the Web client, also queries the dbo.Users table in order to retrieve the actual Username of the subscription owner. Since the user account no longer exists in the dbo.Users table, the stored procedure returns no subscriptions even though the subscription clearly exists in the dbo.RPT_Subscription table.

Resolution

*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*
1. Open SQL Server Management Studio
2. Expand out the ION_Network database and then expand Tables.
3. There should be a table named "dbo.Owners". Right-click on the table and select "Edit Top 200 Rows"
5. Find a valid UserID and copy it to be pasted later.
6. Next go to the table "dbo.RPT_Subscriptions" and right-click on that table and select "Edit Top 200 Rows"
7. Paste the previously copied UserID into the Owner column for the report subscription that was previously missing.

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