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Why isn’t SNMPv3 working properly in Network Management Card AOS versions 3.5.7 and earlier?


Issue

SNMPv3 is not working properly with my Network Management Card (possibly v3.5.7 or below).


Product Line
  • Network Management Card 1 (NMC1) - AP9617, AP9618, AP9619

    Devices with an embedded Network Management Card 1 include (but are not limited to): Metered/Switched Rack PDUs (AP78XX, AP79XX), Rack Automatic Transfer Switches (AP77XX, Environmental Monitoring Units (AP9320, AP9340, Netbotz 200)


Environment
  • All serial numbers
  • NMC1 versions v3.5.7 and below


Cause

In some cases, you may find that one more of the SNMPv3 profiles “timeout” or have communication issues with Network Management Card 1 (AP9617, AP9618, AP9619 and any device with an embedded version of this card).  In such cases, APC has found resetting the card to defaults fixes this issue.


Resolution


AOS versions > v3.5.8 contain the firmware fix for this issue.  Please seek an upgrade if you are experiencing these symptoms.


The steps below only need to be performed as a workaround to the issue if you have AOS 3.5.7 or lower or cannot update.

  1. Login to the NMC Web Interface via the IP address with the correct username/password.
  2. Select the following to Reset the NMC to defaults without losing your network configuration
    1. Administration Tab
    2. General menu selection on the horizontal menu bar
    3. Reset/Reboot menu selection on the Vertical menu bar
    4. Select the Reset All Radio Button
    5. Put a check in the Exclude TCP/IP checkbox
    6. Select the Apply button to start the Reset to Defaults process.
    7. Select the Apply button to confirm the Reset/Reboot Management Interface Confirmation process.
  3. Select the following to Reboot the NMC
    1. Administration Tab
    2. General menu selection on the horizontal menu bar
    3. Reset/Reboot menu selection on the Vertical menu bar
    4. Select the Reboot Management Interface Radio button
    5. Select the Apply button to start the Reboot Management Interface process.
    6. Select the Apply button to confirm the Reset/Reboot Management Interface Confirmation process.
  4. Select the following to setup the SNMPv3 support in the NMC:
    1. Administration Tab
    2. Network menu selection on the horizontal menu bar
    3. Select the SNMPv3 "User Profiles" menu in the Vertical menu bar of the NMC to setup each SNMPv3 User Profile.
    4. Select the user profile that you want to modify
      1. Modify the User Name in the user input field provided.
      2. Modify the Authentication Passphrase in the user input field provided if you plan on using MD-5 Authentication with the SNMPv3 data. NOTE:The password must be 15-32 ASCII characters long.
      3. Modify the Privacy Passphrase in the user input field provided if you plan on using DES encryption with the SNMPv3 data. NOTE:The password must be 15-32 ASCII characters long.
      4. Select the MD-5 radio button in the Authentication Protocol row if you plan on using MD- Authentication with the SNMPv3 data.
      5. Select the DES radio button in the Privacy Protocol row if you plan on using DES encryption with the SNMPv3 data.
      6. Select the Apply button to enable your changes for each profile.
    5. Complete steps i - vi for each profile that you want to create up to a maximum of four.
    6. Select the SNMPv3 "Access Control" menu in the vertical menu bar of the NMC to setup access control for each of the SNMPv3 User Profiles
      1. Select the user profile that you want to give access control to
      2. Select the Enable checkbox to enable SNMPv3 control to a user profile.
      3. Select the User Name of the user profile that you want to enable
      4. Select the NMS IP/Hostname IP Address of the system that will be used to communicate via SNMPv3 to this NMC. NOTE: 0.0.0.0 indicates all systems can interface via SNMPv3 to the NMC as long as the system user profile, authentication passphrases, and encryption passphrases match the NMC.
      5. Select the Apply button to enable the changesSelect the SNMPv3 "access" menu in the vertical menu bar of the NMC to enable SNMPv3 for the NMC.
      6. Select the Enable SNMPv3 access checkbox.
      7. Select the Apply button to enable SNMPv3 for the NMC.

NOTE: The NMC requires that the user logout of the NMC and it will automatically reboot after logout to institute these changes. Upon rebooting, the NMC will take about 5-10 minutes to complete its backend processes needed in order to enable SNMPv3. Upon accessing the web interface during this 5-10 minute period, until this process is complete, the NMC will display a message saying "Please wait while system is booting..." but telnet access will still be available.

施耐德電機Taiwan

Why isn’t SNMPv3 working properly in Network Management Card AOS versions 3.5.7 and earlier?


Issue

SNMPv3 is not working properly with my Network Management Card (possibly v3.5.7 or below).


Product Line
 
  • Network Management Card 1 (NMC1) - AP9617, AP9618, AP9619

    Devices with an embedded Network Management Card 1 include (but are not limited to): Metered/Switched Rack PDUs (AP78XX, AP79XX), Rack Automatic Transfer Switches (AP77XX, Environmental Monitoring Units (AP9320, AP9340, Netbotz 200)

 
Environment
 
  • All serial numbers
  • NMC1 versions v3.5.7 and below


Cause

In some cases, you may find that one more of the SNMPv3 profiles “timeout” or have communication issues with Network Management Card 1 (AP9617, AP9618, AP9619 and any device with an embedded version of this card).  In such cases, APC has found resetting the card to defaults fixes this issue.


Resolution


AOS versions > v3.5.8 contain the firmware fix for this issue.  Please seek an upgrade if you are experiencing these symptoms.


The steps below only need to be performed as a workaround to the issue if you have AOS 3.5.7 or lower or cannot update.

 

 

  1. Login to the NMC Web Interface via the IP address with the correct username/password.
  2. Select the following to Reset the NMC to defaults without losing your network configuration
    1. Administration Tab
    2. General menu selection on the horizontal menu bar
    3. Reset/Reboot menu selection on the Vertical menu bar
    4. Select the Reset All Radio Button
    5. Put a check in the Exclude TCP/IP checkbox
    6. Select the Apply button to start the Reset to Defaults process.
    7. Select the Apply button to confirm the Reset/Reboot Management Interface Confirmation process.
  3. Select the following to Reboot the NMC
    1. Administration Tab
    2. General menu selection on the horizontal menu bar
    3. Reset/Reboot menu selection on the Vertical menu bar
    4. Select the Reboot Management Interface Radio button
    5. Select the Apply button to start the Reboot Management Interface process.
    6. Select the Apply button to confirm the Reset/Reboot Management Interface Confirmation process.
  4. Select the following to setup the SNMPv3 support in the NMC:
    1. Administration Tab
    2. Network menu selection on the horizontal menu bar
    3. Select the  SNMPv3 "User Profiles" menu in the Vertical menu bar of the NMC to setup each SNMPv3 User Profile.
    4. Select the user profile that you want to modify
      1. Modify the User Name in the user input field provided.
      2. Modify the  Authentication Passphrase in the user input field provided if you plan on using MD-5 Authentication with the SNMPv3 data. NOTE: The password must be 15-32 ASCII characters long.
      3. Modify the  Privacy Passphrase in the user input field provided if you plan on using DES encryption with the SNMPv3 data.  NOTE: The password must be 15-32 ASCII characters long.
      4. Select the MD-5 radio button in the Authentication Protocol row if you plan on using MD- Authentication with the SNMPv3 data.
      5. Select the DES radio button in the Privacy Protocol row if you plan on using DES encryption with the SNMPv3 data.
      6. Select the Apply button to enable your changes for each profile.
    5. Complete steps i - vi for each profile that you want to create up to a maximum of four.
    6. Select the SNMPv3 "Access Control" menu in the vertical menu bar of the NMC to setup access control for each of the SNMPv3 User Profiles
      1. Select the user profile that you want to give access control to
      2. Select the Enable checkbox to enable SNMPv3 control to a user profile.
      3. Select the User Name of the user profile that you want to enable
      4. Select the NMS IP/Hostname IP Address of the system that will be used to communicate via SNMPv3 to this NMC.  NOTE:  0.0.0.0 indicates all systems can interface via SNMPv3 to the NMC as long as the system user profile, authentication passphrases, and encryption passphrases match the NMC.
      5. Select the Apply button to enable the changesSelect the SNMPv3 "access" menu in the vertical menu bar of the NMC to enable SNMPv3 for the NMC.
      6. Select the Enable SNMPv3 access checkbox.
      7. Select the Apply button to enable SNMPv3 for the NMC. 

 

NOTE: The NMC requires that the user logout of the NMC and it will automatically reboot after logout to institute these changes. Upon rebooting, the NMC will take about 5-10 minutes to complete its backend processes needed in order to enable SNMPv3. Upon accessing the web interface during this 5-10 minute period, until this process is complete, the NMC will display a message saying "Please wait while system is booting..." but telnet access will still be available.
 

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