Issue
The run report history does not populate when refreshed in the EPSS tool.
Product Line
Power Monitoring Expert 8.2
Power Monitoring Expert 9.x
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Environment
EPSS Report Generator Performance Configuration Tool
Cause
This can happen if Generator groups have the EPS_Available option selected. When the EPS_Available and the EPS_RUN measurement have the exact same timestamp in the database, the 'Refresh run history' button cannot populate the rung history as it can't gather information on that group.
Resolution
To fix this issue find the duplicate timestamps, and change the EPS_Available quantity to be slightly different. For example make the EPS_Available timestamp 1 second after the EPS_RUN measurement. The SQL query below will reveal the duplicate timestamps. Keep in mind that running this query on a large database could take a while to finish. This query will give a list of sources in the database with duplicate timestamps. From that list, one of the duplicate timestamps must be changed as described above.
USE ION_Data
SELECT * FROM
(
SELECT COUNT (*) AS duplicate, sourceID, TimestampUTC FROM datalog2
WHERE QuantityID IN (10950,11148)
GROUP BY SourceID, TimestampUTC
) AS Q
WHERE duplicate > 1
Once there are no longer duplicates, the run history will populate as expected.
To get rid of duplicates run the below script for each timestamp: