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PME 8.x - "There was a problem processing your request." when trying to open a Data Log Viewer in Web Diagrams

Issue
A customer is attempting to open a Data Log Viewer through the Diagrams section of Web Applications.


Product Line
Power Monitoring Expert 8.x

Environment
Web Applications - Diagrams

Cause
If the customer is using Internet Explorer as the web browser, it can default to no selected language in the request header of the web page. This will happen if the  HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\International registry key has a 'AcceptLanguage' value associated with it, and the data for that value is NULL.
If the 'AcceptLanguage' value does not exist at all, Diagrams will use the OS language, however if that value does exist, and it is empty, then Diagrams crashes.

Resolution
Configure the language settings within Internet Explorer.
Select Tools > Internet Options



Click 'Languages'. Within the Language Preference window, click 'Set Language Preferences'.



Select the default language configuration and apply the changes within Internet Options.
Close the browser and reopen to confirm the issue is resolved.



The above changes can also be made with edits to the registry as outlined below

*Warning: This article contains information about editing the registry. Improper changes to the registry can permanently damage the operating system. Always backup the registry before making any changes.*

1) Navigate to HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\International registry key to check if key exist and the value of data.


2) Insert correct data  - e.g. en-US, en; q=0.5

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