You are currently viewing the content available in Vietnam. If you are looking for information for another region, please select the correct country from the top-left dropdown in the page and 'Navigate to Browse FAQs' in the Support menu.
Issue:
An user has several alarm rules configured in the alarm configuration tool, but does not wish to remove each alarm one by one.
Product Line:
Power Monitoring Expert 8.0
Environment:
Power Monitoring Expert Alarm Configuration Tool
Cause:
There is no option to delete all the alarm rules in one single click in the alarm configuration tool.
Resolution:
*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*
1. Close the Alarm Configuration Tool if you have it open.
2. Navigate to SQL Server Management Studio and log in using credentials that have the ability to modify the Application Modules database
3. Click on New Query and enter the following query:
USE ApplicationModules
Delete FROM [Configuration].[ConfigurationValue]
WHERE [ConfigurationKeyId] IN
(SELECT [Id]
FROM [Configuration].[ConfigurationKey]
WHERE [ConfigurationItemId]=
(SELECT [Id]
FROM [Configuration].[ConfigurationItem]
WHERE [ItemIdentifier]='Alarm Rule') );
Delete FROM [Configuration].[ConfigurationKey]
WHERE [ConfigurationItemId]=
(SELECT [Id]
FROM [Configuration].[ConfigurationItem]
WHERE [ItemIdentifier]='Alarm Rule');
GO
4. Reopen the Alarm Configuration Tool to find no alarm rules that are configured.
An user has several alarm rules configured in the alarm configuration tool, but does not wish to remove each alarm one by one.
Product Line:
Power Monitoring Expert 8.0
Environment:
Power Monitoring Expert Alarm Configuration Tool
Cause:
There is no option to delete all the alarm rules in one single click in the alarm configuration tool.
Resolution:
*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*
1. Close the Alarm Configuration Tool if you have it open.
2. Navigate to SQL Server Management Studio and log in using credentials that have the ability to modify the Application Modules database
3. Click on New Query and enter the following query:
USE ApplicationModules
Delete FROM [Configuration].[ConfigurationValue]
WHERE [ConfigurationKeyId] IN
(SELECT [Id]
FROM [Configuration].[ConfigurationKey]
WHERE [ConfigurationItemId]=
(SELECT [Id]
FROM [Configuration].[ConfigurationItem]
WHERE [ItemIdentifier]='Alarm Rule') );
Delete FROM [Configuration].[ConfigurationKey]
WHERE [ConfigurationItemId]=
(SELECT [Id]
FROM [Configuration].[ConfigurationItem]
WHERE [ItemIdentifier]='Alarm Rule');
GO
4. Reopen the Alarm Configuration Tool to find no alarm rules that are configured.