Our Brands

Welcome to the Schneider Electric Website

Welcome to our website.
		
How can we help you today?
You are currently viewing the content available in Vietnam. If you are looking for information for another region, please select the correct country from the top-left dropdown in the page and 'Navigate to Browse FAQs' in the Support menu.
Installing the SQL Express 2016 on Windows 10 fails. Wait on the Database Engine recovery handle failed.

Issue

  • Installing the SQL Express 2016 included in the PME2020 iso file (13.1.4001.0) or directly downloaded from the Microsoft download center fails with error messages such as:
“Component name:                        SQL Server Database Engine Services Instance Features
Component error code:               0x851A001A
Error description:                          Wait on the Database Engine recovery handle failed. Check the SQL Server error log for potential causes.”

aa

  • Installing the SQL Express 2016 downloaded from the Microsoft download center fails with error message such as
“SQL SERVER – Script level upgrade for database ‘master’ failed because upgrade step msdb110_upgrade.sql encountered error 926, state 1, severity 25”

  • The SQL service won’t start normally.
  • The SQL service can be forced to start with trace flag 902 to bypass upgrade script and fix the cause of upgrade script failures (See link 2)

Environment

  • Windows 10 Professional (x64 bits)
  • Microsoft Windows 10 Pro (10.0.18363)

Cause

  • Since the April Windows 10 update there has been an option "Beta: Use Unicode UTF-8 for worldwide language support" when setting regions.
  • SQL Express 2016 did not install correctly, “something" broke in such a way that the SQL Server master database was not able to come online, and the SQL services did not start properly.


Resolution

  • Uninstall SQL Express
  • Go to the control panel
  • Click on regional settings
  • Go to the administrative tab.
  • Go to the language for non-unicode programs “Change system locale…”settings button
  • Uncheck the checkbox use utf-8 for the language support in all the world
aa
  • When prompted, restart your computer. Then, you can deploy the SQL installation and should run successfully
  • Additional information: You might need to make sure the current windows user has been granted privileges to deploy the installation. Refer to link 3 for more information.

Links

Schneider Electric Vietnam

You are currently viewing the content available in Vietnam. If you are looking for information for another region, please select the correct country from the top-left dropdown in the page and 'Navigate to Browse FAQs' in the Support menu.
Installing the SQL Express 2016 on Windows 10 fails. Wait on the Database Engine recovery handle failed.

Issue
 

  • Installing the SQL Express 2016 included in the PME2020 iso file (13.1.4001.0) or directly downloaded from the Microsoft download center fails with error messages such as:
“Component name:                        SQL Server Database Engine Services Instance Features
  Component error code:               0x851A001A
  Error description:                          Wait on the Database Engine recovery handle failed. Check the SQL Server error log for potential causes.”

aa 

 
 

 

  • Installing the SQL Express 2016 downloaded from the Microsoft download center fails with error message such as
“SQL SERVER – Script level upgrade for database ‘master’ failed because upgrade step msdb110_upgrade.sql encountered error 926, state 1, severity 25”

 

  • The SQL service won’t start normally.
  • The SQL service can be forced to start with trace flag 902 to bypass upgrade script and fix the cause of upgrade script failures (See link 2)

Environment

  • Windows 10 Professional (x64 bits)
  • Microsoft Windows 10 Pro (10.0.18363)

Cause

  • Since the April Windows 10 update there has been an option "Beta: Use Unicode UTF-8 for worldwide language support" when setting regions.
  • SQL Express 2016 did not install correctly, “something" broke in such a way that the SQL Server master database was not able to come online, and the SQL services did not start properly.


Resolution

  • Uninstall SQL Express
  • Go to the control panel
  • Click on regional settings
  • Go to the administrative tab.
  • Go to the language for non-unicode programs “Change system locale…”settings button
  • Uncheck the checkbox use utf-8 for the language support in all the world
aa
  • When prompted, restart your computer. Then, you can deploy the SQL installation and should run successfully
  • Additional information: You might need to make sure the current windows user has been granted privileges to deploy the installation. Refer to link 3 for more information.

Links

Schneider Electric Vietnam

Explore more
Category:
Explore more
Category:
Users group

Discuss this topic with experts

Visit our community and get advice from experts and peers on this topic and more
Users group

Discuss this topic with experts

Visit our community and get advice from experts and peers on this topic and more
Explore more
Category:
Explore more
Category:

Need help?

  • Start here!

    Find answers now. Search for a solution on your own, or connect with one of our experts.

  • Contact Support

    Reach out to our customer care team to receive more information, technical support, assistance with complaints and more.

  • Where to buy?

    Easily find the nearest Schneider Electric distributor in your location.

  • Search FAQs

    Search topic-related frequently asked questions to find answers you need.

  • Contact Sales

    Start your sales inquiry online and an expert will connect with you.

I'd like to receive news and commercial info from Schneider Electric and its affiliates via electronic communication means such as email, and I agree to the collection of information on the opening and clicks on these emails (using invisible pixels in the images), to measure performance of our communications and improve them. For more details, please read our Privacy Policy.

  • Products Documentation
  • Software Downloads
  • Product Selector
  • Product Substitution and Replacement
  • Help and Contact Center
  • Find our Offices
  • Get a Quote
  • Where to buy
  • Company Profile
  • Report a misconduct
  • Accessibility
  • Investors
  • EcoStruxure
  • Job Search
  • Blog
  • Privacy Policy
  • Cookie Notice
  • Terms of use
  • Change your cookie settings
Your browser is out of date and has known security issues.

It also may not display all features of this website or other websites.

Please upgrade your browser to access all of the features of this website.

Latest version for Google Chrome, Mozilla Firefox or Microsoft Edgeis recommended for optimal functionality.